Roadfly.com         Roadfly Home | Features | Car Review Videos | Car Reviews | Cars For Sale | Used Car Parts Classifieds | Forum | Car Review Archives | Forum Archives Index



PDA



77300d123
05-22-2006, 09:38 AM
I've got a question for the trans experts, my 77 300D has set awhile and now when it is at operating temp when you stop it does'nt stay in gear you can hold the brake give it a little throutle and it'll go in gear wih a little lurch like it's taking up some slack I believe its a pressure problem since this year benz has no vacuum shift, tried a can of seal conditioner, helped very little. The car shifts fine when under way acts perfect until you stop. I remember Dodges trans having an exrenal pressure adjust that could be set, can this be done on this trans

Daniel H
05-22-2006, 06:59 PM
Have you tried a fluid and filter change yet?
Daniel H

dembooks
05-23-2006, 10:10 AM
...I agree with Daniel,
first remove the oil pan, inspect&smell the fluid.
If it smells like a burnt electrical motor, and
the oil is black, and black sediment is stuck to the bottom of the pan - go no further. Order an exchange trans.
After changing the oil (and drain the torque converter also)
and filter, look for a Reverse Band/First Gear adjustment
with lock nut just above the oil pan seal surface. Loosen the lock nut and give it a 1/2 turn in - and road test.
Reverse and first gear share the same band.

Good Luck.

77300d123
05-23-2006, 01:12 PM
Yes I have done a filter & fluid change and it was clean but was done before I bought the car so don't know the condition then. I just got a trans manual and plan on adjusting the throttle pressure rod ,the Benz shifts a little late and also the modulator pressure, books says all have to be close to get full system pressure. I didn't catch the band adust part,but will try that to, will let you know how it goes.
Thanks Larry H.


Roadfly Home | Car Reviews | Forum Archives Index