Roadfly.com         Roadfly Home | Features | Car Review Videos | Car Reviews | Cars For Sale | Used Car Parts Classifieds | Forum | Car Review Archives | Forum Archives Index



PDA



dwrees
07-30-2006, 07:42 PM
Hi...have just come across this message board and am hoping someone can help me.

We have a 2000 CLK320 which we purchased new. It now has 50,000 km and have recently starting having electrical problems. Are these common in CLKs?

Three months ago,while out for dinner, the headlights would not shut off no matter what we did. I got the car to the dealer who was perplexed but recommended that the headlight switch be replaced (at $600!). Then the battery started going flat - not surprisingly after 6 years so I had the battery replaced. Yesterday the car just died, while driving. All the warning lights came on but, after several tries, the car did start again. The dash lights however would not - I had to turn the light switch to 'park' or to 'headlight' for them to come on. Today, the same problem. The car died while driving but, this time, would not start - so it's been towed to the dealer. I'm quite perturbed.

It suggests something is wrong with the electrical system - any thoughts? Thanks in advance for any suggestions or help.

kory atkinson
09-06-2006, 08:56 PM
My 2000 clk320 is doing the exact same thing... if you can let me know what it was it would be greatly appreciated.... thanks

Kory

dwrees
08-16-2007, 10:15 PM
For the benefit of any others with this problem it turned out to be the crankshaft position sensor, apparently a relatively common problem on CLK's. Cost was about $250 to replace, not counting the towing bills and aggravation.


Roadfly Home | Car Reviews | Forum Archives Index