Roadfly.com         Roadfly Home | Features | Car Review Videos | Car Reviews | Cars For Sale | Used Car Parts Classifieds | Forum | Car Review Archives | Forum Archives Index



PDA



fongman
10-26-2007, 09:31 PM
88' m6 smog is due brought it in to Test only station and the guy tells me it flunked. Ok I figured emissions. No he says "check engine light failed" must be burned out. Take it home and find there is no socket or bulb in that slot. Did a search in forum and from what I can tell 635csi has "check engine light". s38 does not. Any one with a s38 have a check engine light? I think only 635csi has it.
Looked at my old smog check papers from 2005 doesn't show visual check engine light test. 2007 now shows visual test for check engine light.

How do you get BAR to correct inaccuracies. I've seen many inaccuracies in their emissions requirement list before. Lucky for me I was able to show that it was incorrect to the tester but this was on some old Chevrolets.

It may be hell to get s38 engines passed this year in CA. Any one else run into this problem yet. Well may be I'm the first at something.

Thanks for any feedback.

bmw635
10-27-2007, 12:56 AM
Peter- S. CA.
86 Euro635 3.7L, SS MAF, Bilstein& Eibach.
98 740IL Supercharge AC Schnitzer with NAV & TV.
<embed src="http://apps.rockyou.com/rockyou.swf?instanceid=30417739&ver=102906" quality="high" salign="lt" width="477" height="343" wmode="transparent" name="rockyou" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer"/><br><a target="_BLANK"

cw6er
10-27-2007, 01:35 AM

fongman
10-27-2007, 08:54 AM
The check light would normally be two spots to the right of high beam. Looking at the owners manual looks like it's visiable on 635csi without light. Mine appears blacken out and you need a flashlight to see it. That's how the technician found it.

fongman
10-27-2007, 08:56 AM

fongman
10-27-2007, 09:15 AM
Wiring diagram shows cel for 3.5l engine only. Should be gray and green-white wire from fuse 10.

cw6er
10-28-2007, 03:25 AM
have them before perhaps the '88/'89 with the Motronic 1.1. These ECU's could flash out some codes, but there is no indication of a check engine light on the ETM's

fongman
10-28-2007, 11:26 AM
Looked at both 87' and 88' diagram and it shows CEL only on 88+ 635csi not for m6 or 87' and under. What a hassle this is after taking cluster out. BAR has wrong information.
Thanks for looking. I feel better now.

Ray7er6ers5er3er
10-28-2007, 10:22 PM
test facility. I got in a fight with one of these guys a few years back over the si inspection light.


Roadfly Home | Car Reviews | Forum Archives Index