Roadfly.com         Roadfly Home | Features | Car Review Videos | Car Reviews | Cars For Sale | Used Car Parts Classifieds | Forum | Car Review Archives | Forum Archives Index



PDA



4dixie
06-01-2008, 04:48 PM
I have a 1994 S-500 and the blower does not operate when the heat or Ac is turned on. I tested the blower motor by applying power directly to the motor and it operates normally. I would like to eliminate the regulator but not sure how to test it to see if it is functioning correctly.

I did place a jumper between the blue and black wire terminal on the regulator and the blower fan kicks on high, but all i am doing is giving the motor a ground from the regulator.

I am not sure how the regulator operates or how to test it, so if anyone has some advice it would greatly appreciated.

Thanks !!!!!

harvey
08-29-2009, 04:50 PM
You "have" diagnosed the problem already. replace the regulator. Not overly expensive. 2 screws, 2 elec. connectors, 1 elec. plug. Takes 20 minutes.

Bill
11-29-2010, 10:48 PM
Hello,

I had the same problem. No blower operation at all. I put straight 12 volts to the blower to verify that it was good. Went full blast. I bypassed the regulator to verify that the voltage was good to the regulator. Found a brand new one on ebay for 45.00 dollars. all has been great. The very very poor codition of the cabin air filter can cause more strain on the regulator I think and help it burn out sooner. The prev. owner had a lack of care.

Bill


Roadfly Home | Car Reviews | Forum Archives Index