Roadfly.com         Roadfly Home | Features | Car Review Videos | Car Reviews | Cars For Sale | Used Car Parts Classifieds | Forum | Car Review Archives | Forum Archives Index



PDA



Isiah
02-24-2000, 06:30 PM
I am trying to diagnose my self leveling. It doesn't seem to work at all. I thought my ride level was fine until I took my car to the shop and found out it had one leaking hose and the inside of my driver's side rear tire was showing steel belts. I am going to fix the hose but I want to make sure the rest of the system is working. Does anybody have a step by step diagnosis that they would advise me of doing? I also noticed that I have a slight knock that seems to be at the upper end of the strut when I bounce the car up and down. Has anybody had a problem with bad mounts or with loose mounts? <p>Isiah<br>

John
02-25-2000, 12:38 PM
Isiah,<p>I've got that little rattle at the top of the strut tower as well as a little leakage at the strut. It disappears after warm up and a few suspension cycles. So my guess is an air bubble in the hydraulic system (the car sits for long periods of time).<p>As far as cutting the tires, before the subframe bushing replacement I cut in inside tread on one of the tires pretty badly and quickly. Aside from a total lack of dampening, I can't see where a malfunctioning self leveling system could cause this much grief. Check the subframe. When I changed mine it sure accentuated the faults in the front suspension. Ended up dumping a couple hundred more in control arms, tie rods, struts and strut bearings!!<p>John 88 735iL (226K)<br>79 320i (250k)<br>95 Disco<p><i>: I am trying to diagnose my self leveling. It doesn't seem to work at all. I thought my ride level was fine until I took my car to the shop and found out it had one leaking hose and the inside of my driver's side rear tire was showing steel belts. I am going to fix the hose but I want to make sure the rest of the system is working. Does anybody have a step by step diagnosis that they would advise me of doing? I also noticed that I have a slight knock that seems to be at the upper end of the strut when I bounce the car up and down. Has anybody had a problem with bad mounts or with loose mounts? <p>: Isiah<p></i>


Roadfly Home | Car Reviews | Forum Archives Index