Roadfly.com         Roadfly Home | Features | Car Review Videos | Car Reviews | Cars For Sale | Used Car Parts Classifieds | Forum | Car Review Archives | Forum Archives Index



PDA



Mario
10-19-2002, 03:26 PM
I have a 1973 XKE with the following problem:

When I start the engine, it runs for about 15 minutes and then starts to misfire and stalls. If I attempt to restart, the engine turns but does not start for at least 10 minutes, then will start normally again. But if it runs again for another 15 minutes, the same thing happens. I know it is not a gas related problem because I replaced the fuel pump and it works perfectly. I replaced the ignition amplifier, iginition coil, pick up module assembly, electronic timing rotor and high tension rotor but to no avail.

Any help would be greatly appreciated. Please reply to
wykes99@rogers.com

Chris
10-20-2002, 04:47 AM
Im not sure if the xke is anything like the xjs in terms of its fuel system, but just in case it is, that sounds very much like a common problem where there is a filter screen in a surge tank which when the engine is running, has all the fuel pass through it - if the tank is full of crud, after a while that all gets stuck to the filter, then when you stop the engine the crud drops back to the bottom. repeat.

alnmo
11-26-2002, 10:58 AM
I have a friend who is looking for a mechanic in the North Orange County area (CA) who can replace the transmission seals on his XKE.

James Zimmer
05-20-2003, 03:12 PM
I have a 1973 SIII E-type and I have had the same problem. There are several possibilities: a. fuel filter ( in boot) see shop manual. b. dirt or rust in the fuel tank. c. fuel pump(R wing).
What to do. 1. Change fuel filter. This may work but is probably not the problem. 2. Drain the fuel tank. (see drain at bottom of the tank protruding through the bottom of the car). 3. If there is a lot of rust and dirt flush tank. It may be necessary to take the tank out and have it professional cleaned and sealed. ( You can try to clean coat the tank yourself but I made a mess of this and then had to have it redone professionally. 4. After you have done all this the problem may still not be solved. Then you will realize that is was the weak old SU fuel pump all along. If you have an old fuel pump this a prime suspect. Although relatively expensive you can' with aid of the shop manual change it yourself.
Hope that helps.
JZ.


Roadfly Home | Car Reviews | Forum Archives Index