Roadfly.com         Roadfly Home | Features | Car Review Videos | Car Reviews | Cars For Sale | Used Car Parts Classifieds | Forum | Car Review Archives | Forum Archives Index



PDA

View Full Version : Problem with New X350





StevenEsqtwo
09-20-2004, 02:48 AM
Hi folks. New member and fist time poster here. My wife and I just became Jaguar owners in January with a new red X350 for her and a gorgeous white X308 Soverign for me. We have been enjoying both cars tremendously, moving up from Infiniti Q45s.

The 350 is going in for service on Tuesday. There is a very strange sound coming from the right rear when the car accellerates from coasting. I know this may sound silly but the noise is almost like the sound a seal makes... "arfff"... Could it be the tranny (or maybe differential?) is slipping?

We live in Los Angeles and brought it to Hornburg several weeks ago when the problem first surfaced. The car also has a nasty hesitation problem, according to my wife. Hornburg was clueless, unprofessional and a bunch of clowns. A total embarassment. Very surprising since we had been treated so well by the Infiniti service personnel since the early 90s and thought Jaguar would pull out all the stops for its customers. We will try Galpin next.

This begs the question, are there ANY competent and courteous Jag mechanics in Los Angeles? I want to enjoy these beautiful cars for many years to come and need to develop the right relationship with a reputable/honest shop. Cheers!

Richard H
09-21-2004, 02:11 PM
Hi Steven-

I have a '04 XJR that I purchased from Bauer Jaguar in OC. They have an excellent service department w/specialists in house for the various systems. I'm extremely pleased w/the attentiveness and professionalism that they have exibited so far. I believe Galpin has the specialist program as well. Sounds like your wife might have a bad wheel bearing. Good Luck!

rebelreiver
09-22-2004, 12:54 PM
I have had very good treatment at Jaguar of South Bay on Pacific Coast HWY in Torrance. They have gone the extra mile for me.

StevenEsqtwo
09-23-2004, 12:29 AM
Thanks folks. So far, Galpin was unable to find anything wrong.

lostideas
10-05-2004, 05:58 PM
depending on your vin range there was a issue with rear brakes sticking .. some still stick out of the vin range due to park brake cable issues


Roadfly Home | Features | Car Review Videos | Car Reviews | Cars For Sale | Used Car Parts Classifieds | Forum | Car Review Archives | Forum Archives Index