+ Reply to Thread
Results 1 to 16 of 16

Thread: No Spark

  1. #1
    Michael in MD
    Guest
    Location
    , ,
    Member No: Michael in MD's Avatar


    Yes | No

    No Spark

    Hi Guys,

    I in a jamb with this car and the mechanic doesn't know what else to do.

    We have no spark... the engine turns over and over but nothing ignites.

    We've replaced both main and fuel relays

    We've now replaced both sensors for the crank that are on the bell housing

    We've swapped out the coil for one known to work. He said he's getting positive side power but no trigger (I have no idea what this means)

    Without wiring diagrams he feels there's nothing else he can do, or doesn't know what else to do.

    Suggested it is the brain (ECU) but has no way to check it.

    The tach doesn't jump or move at all while cranking the engine

    Thoughts?

    This is the problem I had weeks ago when it just died while driving down the road.

    Thanks for any help you can give us.

    Michael [stranded] in MD



  2. #2
    Sheldon
    Guest
    Location
    , ,
    Member No: Sheldon's Avatar


    Yes | No

    Re: No Spark - send the ECU to Programma

    For about $80 they will go through it and diagnose if there are any problems.

    -Sheldon
    138k

  3. #3
    Registered Member
    Location
    , ,
    Member No: 25251 pm179 is an unknown quantity at this point pm179's Avatar
    Join Date
    Jan 2002
    Posts
    201
    Rep Power
    0


    Yes | No

    Re: No Spark - send the ECU to Programma

    Thanks Sheldon,

    I posted here and on the Yahoo group and all responses say to look for ECU problems. Will do ASAP

    Gotta love these old cars... 200k+

    Michael

  4. #4
    Registered Member
    Location
    Westminster, MD, United States
    Member No: 9058 mike325i is an unknown quantity at this point mike325i's Avatar
    Join Date
    Apr 2001
    Posts
    558
    Rep Power
    0


    Yes | No

    Re: No Spark

    mike, send me an e-mail and let me know where your located. I'd be willing to drive over and swap your ecu into my car so we can see if we get the same symptom. That would be a pretty good indicator that your ecu is bad.

    mike

    BMWCCA #285348 National Capital Chapter
    '88 M5 black/tan 5-spd 145k
    '91 325i white/black 5-spd 212k
    '91 318is red/black 5-spd 135k
    '95 525i gray/tan auto/vanos 122k

  5. #5
    Registered Member
    Location
    Westminster, MD, United States
    Member No: 9058 mike325i is an unknown quantity at this point mike325i's Avatar
    Join Date
    Apr 2001
    Posts
    558
    Rep Power
    0


    Yes | No

    meant to say "good or bad"

    mike

    BMWCCA #285348 National Capital Chapter
    '88 M5 black/tan 5-spd 145k
    '91 325i white/black 5-spd 212k
    '91 318is red/black 5-spd 135k
    '95 525i gray/tan auto/vanos 122k

  6. #6
    Registered Member
    Location
    , ,
    Member No: 25251 pm179 is an unknown quantity at this point pm179's Avatar
    Join Date
    Jan 2002
    Posts
    201
    Rep Power
    0


    Yes | No

    Thanks Mike... email sent


  7. #7
    Registered Member
    Location
    Stamford, CT, United States
    Member No: 11081 gofast1 is an unknown quantity at this point gofast1's Avatar
    Join Date
    Jun 2001
    Posts
    33
    Rep Power
    0


    Yes | No

    Did you try the 'code' box under the steering whl

    This box contains a relay that prevents the ECU from turning on the fuel pump OR spark. You can jump it as a stopgap. Or, open it up, and see if any of the soldered traces are broken. Mine were, I soldered a wire to bridge over the gap, and that got my M5 running again.

    Samir Shah.
    88 M5
    86 635
    99 540i
    81 745i
    91 Lotus Elan
    06 Lotus Exige (or order)

    Samir Shah
    81 745i
    86 635csi
    88 M5
    99 540iT
    91 Lotus Elan

  8. #8
    AJA
    Guest
    Location
    , ,
    Member No: AJA's Avatar


    Yes | No

    Re: No Spark - send the ECU to Programma

    Michael,
    If you are able to eliminate the ECU I have a couple of suggestions. I just went through a very similar experience. Let me know if I can help! Art

  9. #9
    Registered Member
    Location
    , ,
    Member No: 25251 pm179 is an unknown quantity at this point pm179's Avatar
    Join Date
    Jan 2002
    Posts
    201
    Rep Power
    0


    Yes | No

    Update... all is well again

    Hi All,

    I did send my ECU out to Programa and they fixed it (I have no idea WHAT they did though...) We put it back in the car and it fired right up.

    However, we discovered other issues that had to be straightened out. I ended up replacing the coil, plugs, coolant sensors & TPS, the major problem being the weak coil.

    I also replaced my problem custom e34 headers with the stock manifolds, and installed the track pipe in place of the DEC cat.

    The car runs GREAT now, with pulling power all the way to redline. Removing the cat was worth 20 HP at the very top end. In all the repairs I did re-install the factory chip, removing a Gen 2 or 3 Dinan chip. This is messing with my fuel milage, also I now know what folks mean by a flat spot or notch at 4k ;-)

    Thanks to everyone that helped me get this thing to where it is today... much appreciated!!

    Michael


  10. #10
    ernest
    Guest
    Location
    , ,
    Member No: ernest's Avatar


    Yes | No

    maybe try a jim c. chip

    That is what I am running and it was a big improvement over the stock chip...removed the flat spot at 4k especially under partial throttle. I am running it with a track pipe and exhaust cam gear....although I really couldnt tell much difference when I installed the cam gear, at least the butt dyno couldnt.

    ernest

  11. #11
    Michael in MD
    Guest
    Location
    , ,
    Member No: Michael in MD's Avatar


    Yes | No

    How did the Jim C chip effect fuel mileage?

    ...any noticeable differences?

    Thanks for the tip,

    Michael

  12. #12
    ernest
    Guest
    Location
    , ,
    Member No: ernest's Avatar


    Yes | No

    I really dont keep up with it that closely....

    but it will get 20+ on the highway running a steady speed, probably close to 18 around town, normal driving. Personally, the jc chip is a big improvement over stock.

    ernest

  13. #13
    Scottie
    Guest
    Location
    , ,
    Member No: Scottie's Avatar


    Yes | No

    If you don't mind me asking....

    what did programma charge for the overhaul?

  14. #14
    Registered Member
    Location
    , ,
    Member No: 25251 pm179 is an unknown quantity at this point pm179's Avatar
    Join Date
    Jan 2002
    Posts
    201
    Rep Power
    0


    Yes | No

    Re: If you don't mind me asking....

    Hi Scottie,

    I don't mind... you're always willing to help me

    $479 including shipping! Ouch... but when you get to the point I was at you don't have many choices. I could have opened it up myself and start to solder stuff myself -- Naa

    Michael

  15. #15
    I miss stuff! --Scottie :-)
    Guest
    Location
    , ,
    Member No: I miss stuff! --Scottie :-)'s Avatar


    Yes | No

    I'm about to do just that on a 013 box....


  16. #16
    m5e28 video
    Guest
    Location
    , ,
    Member No: m5e28 video's Avatar


    Yes | No

    Re: No Spark


+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum