+ Reply to Thread
Results 1 to 5 of 5

Hybrid View

  1. #1
    JeffFL745Li
    Guest
    Location
    , ,
    Member No: JeffFL745Li's Avatar


    Yes | No

    A/C auto switch not working right - Geez Tech?

    My passenger-side auto switch for the A/C will turn itself off every once in a while.

    On the I-drive screen at the bottom there is the left and right fan displays that always say 'Auto'. What will happen is as I am driving the passenger one will switch to the white bar that controls fan speed (the green light on the Auto switch actually stays on) and the fan stays on whatever speed it happened to be on when it switched. I have to press the Auto button again and it will resume working properly - sometimes for 5 minutes, sometimes for a month.

    I can't reproduce the problem and it is not caused by bumps or anything. It happens whether it is heating or cooling the car.

    I've had the dealer look at it twice and they said they couldn't reproduce it and everything tested out fine. Ironically, both times they looked at it, it worked right (stayed on Auto) for a few months then started acting up again.

    If anybody has had a similar problem and figured out how to fix it, I would appreciate it.

  2. #2
    Registered Member
    Location
    BFE, BFE, United States
    Member No: 103164 GeezTech is an unknown quantity at this point GeezTech's Avatar
    Join Date
    Mar 2004
    Posts
    10,978
    Rep Power
    0


    Yes | No

    Strange, it sounds like it is getting.............

    ....a false fan speed input from the knob as this is what will take it out of "auto".
    I have seen other reports here of the display flashing at times and the fix there was a new A/C panel which may be the case for your car. The problem the dealer has is that the panel may not be setting a fault snce it "thinks" the fan speed input is coming from the knob being turned by someone in the car, even though it actually isn't.
    If they take your word for it then they may replace the panel and go from there. I'm sure they have done software changes for other reasons and this problem may still persist, right?

  3. #3
    JeffFL745Li
    Guest
    Location
    , ,
    Member No: JeffFL745Li's Avatar


    Yes | No

    Re: Strange, it sounds like it is getting.............

    Yes, both times I took it in they did a recall and updated software and I thought it was fixed...only to return months later.

  4. #4
    scottw
    Guest
    Location
    , ,
    Member No: scottw's Avatar


    Yes | No

    Any final resolution here?


  5. #5
    Registered Member
    Location
    Suwanee, GA, United States
    Member No: 21095 scottw57 is an unknown quantity at this point scottw57's Avatar
    Join Date
    Dec 2001
    Posts
    597
    Rep Power
    0


    Yes | No

    Any resolution? I have problem. Thanks

    Suwanee, Georgia (Atlanta)
    2004 745li
    Sterling Gray Metallic
    Black/Natural Brown Leather
    Premium Sound with Sirius Satellite Radio
    PDC, Conv. pkg, Elec.sunshades, 19" custom Bereyn wheels

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum