+ Reply to Thread
Page 11 of 18 FirstFirst ... 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 LastLast
Results 201 to 220 of 351
  1. #201
    Kummy
    Guest
    Location
    , ,
    Member No: Kummy's Avatar


    Yes | No

    99 328i M52 - Vanos and oil level light

    I have the exact symptoms as illustrated above, which started the past winter, I also noticed around the same time that the Oil Level light (amber) comes on after I start the vehicle for up to 20 sec then goes away ( Oil is fine). Are these related or do I also have a faulty oil level sensor? The idle thing happens most morning only and then when I drive away it seems to go away. I do notice a degradation in performance… What is the best thing to do, should I wait until for a possible find of some new O rings? Will things get worse or damage anything else? Can I change this myself very handy.. If so does anyone have instructions on how to change?


  2. #202
    Bad Email Address on File
    Location
    Santa Rosa, CA, United States
    Member No: 136503 George_H is an unknown quantity at this point George_H's Avatar
    Join Date
    Jan 2006
    Posts
    2
    Rep Power
    0


    Yes | No

    I'm a vanos victim too.............

    My 2000 528 has the vanos cold-start stutter as well. Excellent write up! Let us know what we can do to get someone at BMW off their tails and doing something. If they only knew how many people ask me how I like my BMW...............2000 528i

  3. #203
    SRR2
    Guest
    Location
    , ,
    Member No: SRR2's Avatar


    Yes | No

    I have bad news for you.

    Have you seen ValveTronic? And you thought Vanos was complicated!! HAH! Just wait until the field failures start with VT technology. We'll have new BMWs sitting by the side of the road all over the place. VT is brilliant engineering, but when it craps, that's all she wrote. You are not going anywhere.

  4. #204
    Registered Member
    Location
    Charlottesville, VA, United States
    Member No: 65135 smarazita is an unknown quantity at this point smarazita's Avatar
    Join Date
    Jan 2003
    Posts
    16
    Rep Power
    0


    Yes | No

    Re: 6-cyl double vanos problem assessment

    1999 528iT, started double vanos problem idle dip Nov 2004 at 47K miles. Now have about 62K mi.

    Same symptoms, only during ambient temps below about 55-60 deg F.

    Any progress with BMWNA?

  5. #205
    Tonico
    Guest
    Location
    , ,
    Member No: Tonico's Avatar


    Yes | No

    Re: 6-cyl double vanos problem assessment

    Guys,
    I also live in Va and have the same issue during the winter wity my 528i-00. Can wehave the name of the c/S agent. I think its time to flood BMW with calls.

    Regards
    Tonico

  6. #206
    klw
    Guest
    Location
    , ,
    Member No: klw's Avatar


    Yes | No

    hmmm.... logic flaw I think.

    Nice writeup but I see some logical flaws.

    If the seals were the issue then emissions problems, performance issues and shortened Cat life would be a likely extrapolation. However, these problems are certainly not being reported at the same frequency as the M52TU stall problem. I can't believe that BMW would deliberatly tamper with OBC data just to cover up a Vanos issue thus explaining why emmissions tests failures aren't showing up at the same frequency level. Besides, on my 2000 528i which had this problem, I never encountered a performance or gas mileage degredation issues which was also predicted by the seal issue. I put 50,000 miles on that car with no Cat problems either. You'd think that M52TU equipped BMW's would be going through CAT converters due to incorrect temp control caused by internal EGR failures.

    Logically therefore, if the above problems aren't as rampant as the Vanos problem obviously is then the Vanos problem isn't tied due to an error in your prediction rationale. Perhaps this could be because the Vanos system performs correctly once operating temps have been achieved. Given this, BMW may have correctly decided to simply recode the DME to correct the stall situation. This is why MY2001 and > BMWs don't experience the issue.

    In light of this, we should be clamoring for a DME firmware upgrade or total replacement on M52TU equipped BMW's IMO.

  7. #207
    loach1
    Guest
    Location
    , ,
    Member No: loach1's Avatar


    Yes | No

    Possibly.....

    The only confirmed symptom is stalling/idle flutter. The performance degradation is a subjective measure experienced by some, but not all owners. If the VANOS operates correctly at operating temperature then a firmware change might overcome the stalling problem, but may impact the cold start emissions - I believe the VANOS is trying to heat the cats as quickly as possible to meet the LEV requirements?

    In any case, if a programming whiz could do something like the Shark Injector upgrade and sell it for (much) less than an installed VANOS, it looks like there is a market hungry for such a product. Was it Jim Conforti (sp) that developed the Shark Injector? Maybe he is unaware of this thread?

    I have a simple timer relay that can disable the VANOS during start up for a selectable amount of time that cures this problem, but it isn't as clean as re-flashing a ROM.

  8. #208
    klw
    Guest
    Location
    , ,
    Member No: klw's Avatar


    Yes | No

    When was "fly by wire" accelerator pedal intro'd?

    My 2003 530I has this feature. There is no mechnical linkage between my accelerator pedal and the engine. This changes DME coding significantly as it adds fully computerized control over air intake with near instantaneous response. Did this change occur in 2001 and if so could it be related to the disappearance of the Vanos issue? If this is the case, it would go a long way towards explaining why BMW hasn't come forward with a DME fix for the M53TU.

  9. #209
    klw
    Guest
    Location
    , ,
    Member No: klw's Avatar


    Yes | No

    What I'm saying here is...

    That the new level of air control is what actually gave BMW engineers a way to work around the VANOS problem with DME coding. They realized that the seals in the VANOS module, as they wore, became increasingly bad at functioning during cold weather. So, the DME fix invoked a new cold start routine that took advantage of the increased control over air/fuel to work around the issue. Since the Vanos seals functioned correctly when warm, a mechanical fix was deemed unnecessary.

  10. #210
    Registered Member
    Location
    Raleigh, NC, United States
    Member No: 111493 rajaieq is an unknown quantity at this point rajaieq's Avatar
    Join Date
    Aug 2004
    Posts
    1,433
    Rep Power
    0


    Yes | No

    Re: hmmm.... logic flaw I think.

    You make some good points.

    Here’s some of the information we know.

    1. One vonos problem was resolved by replacing both intake and exhaust pitons (seals). The vanos problem is always solved by replacing the vanos.
    2. Three people have looked at the inner O-rings on 2+ failing vanoses and have noted their deterioration; hardening, flattening, and likely shrinkage. Loach who’s a semi expert noted this. A third person who’s an expert in the field said: “Yes, the energizing o-ring has age hardened resulting in loss of seal at the cylinder surface. This is the failure, without doubt.”
    3. When the pistons or the whole vanos is replaced owners have noted performance improvements. These improvements are somewhat subtle and not all might have noted them. Some might not have experienced them. My performance improvements were clear. Loach will also note having performance improvements.
    4. Cars with this failing double vanos are not experiencing cat failures. The ability to place the cats close to the engine due to effective EGR is a hypothesis. We have not found any solid information on this, yet.
    5. Owners are not reporting EGR emissions test failures. It’s not clear how many states are testing for EGR and with what capacity. I understand California has only recently incorporated dyno’s into the test process.
    6. It is wrong to say that since the vanos problems occur only when cold then the vanos functions properly when warm. The vanos problem occurs when the DME is running the cat warm-up algorithm. This is run at cold weather after the engine (and vanos) has initially warmed up. This algorithm would need to be run again when the engine is at operating temperature to show there is a difference. At the start of the vanos problem oscillations the car can be driven without any indication of vanos dysfunction and when the car shortly comes to idle the vanos problem oscillations recur. There’s also the indication of performance improvements after replacing the vanos which indicate vanos dysfunction at operating temperatures.


    It would be useful if we could find a way to instigate the cat warm-up algorithm when the engine was at normal operating temperatures. This would help clarify the vanos function at normal operating temperatures.

    From the recent California emissions testing post, the EGR was tested at 15 mph and 25 mph. I suspect to truly test the EGR the engine would need to be fully warmed up and run at high rpms. NOx is created at 2500+ F combustion temperatures. Of course I’m far from an expert in this field.
    It would be useful to have EGR tested before and after vanos replacement. The vanos cold weather oscillation symptoms indicate a failing vanos, but not necessarily a fully dysfunctional vanos. Thus EGR could be functional, but degraded.

    You mention not having performance degradation with the vanos problem. Vanos performance losses would be difficult to denote, especially as they are likely incremental over time. Performance enhancements after replacing the vanos are immediate and thus more notable.

    Both Loach and I had the vanos problem for more than one winter before replacing the vanos. The vanos function likely degrades slowly overtime as the o-rings further shrink and harden. Thus it might be that we were more likely to note performance enhancements.

    Inner elastomer O-ring deterioration is likely linked to acidic oil. As engine oil ages it becomes more acidic. Thus infrequent oil changes will likely degrade the vanos function faster.

    I doubt the premise that a shrunk and hardened elastomer o-ring could somehow function better under temperature. It would be nice if others in the know-how could weigh in on this.

    I agree with you that cats and EGR tests have not been failing, but I don’t believe this necessarily translates to a conclusion that the vanos is operating properly at temperature. I hope there will be further information and assessment that will help reconcile all the facts collected.

    Thanks for the relevant input.
    Rajaie
    528i 5sp 06/00

  11. #211
    Registered Member
    Location
    Raleigh, NC, United States
    Member No: 111493 rajaieq is an unknown quantity at this point rajaieq's Avatar
    Join Date
    Aug 2004
    Posts
    1,433
    Rep Power
    0


    Yes | No

    Re: 99 328i M52 - Vanos and oil level light

    As you can see from the testimonials, the problem is not usually related to the oil light. You might want to do a search here on the oil light problem. I doubt they’re related.

    I don’t know that anyone can give clear advice on how to deal with your vanos problem. I would replace it myself, like you suggest. There’s no indication BMW is about to address the problem. All indications are they’ve dug in against doing anything.

    As noted in the final section of the writeup, to replace the vanos you need to remove the fan/shroud, valve cover, and unbolt vanos from the splined shafts and head. You’ll probably also want to replace the vanos gasket. If your valve cover gaskets are due (60-80k), this would be a good time to replace them. You need the gasket set and 15 bolt rubber grommets.
    Here’s a link where I describe the fan/shroud removal.
    http://bimmer.roadfly.com/bmw/forums/e39/7390345-1.html
    I had forgotten to mention removing the auxiliary water pump from the shroud (also remove electrical connector).

    Removing the valve cover is not awfully complicated. As I recall: Remove the two engine covers. Remove the two ground wires at cyl 1 & 6 (at coil). Remove the coil harness ground wire at cyl 3 (at head). Remove the coil electrical connectors. Withdraw the coil electrical harness. Remove each coil/boot. Disconnect the O2 sensors and cables from the brackets running along the passenger side. Remove the passenger side rear corner silver metal retainer. Pull it strait up or it’ll break (if breaks no problem). Remove cover 15 bolts/washers/grommets; 11 around the perimeter, and 4 down the center. Pry between the gasket and head surface with a paint scraper at the front half moons (sealant). Be careful not to damage the head matting surface. Place a wood block against the cover perimeter and hit the block with a dead blow hammer. The cover will eventually break loose.

    Once the valve cover is removed you’ll be able to fully see the vanos. Remove the two (intake & exhaust) front outside plastic caps on the two pistons/cylinders. Remove the bolt (*left hand thread*)under each cap which mounts the vanos piston to the splined shaft (hex ?). Remove the electrical connectors on the vanos solenoids and exhaust camshaft position sensor. Remove the oil line feed on the vanos intake side (beside solenoid). Unbolt nuts at bottom end of vanos mounting it to engine head. Pull vanos forward and out.
    The vanos has many oil passages and they’re all full of oil. Every time you twist the vanos oil will leak. Be prepared with rags and small containers; even a plastic bag.
    Installation is the reverse of removal. Be sure to clean and place sealant at the front and rear half moon upper corners and at the vanos to head top matting cracks.

    I’m sure there's something missing, but this should get you there.
    Rajaie
    528i 5sp 06/00

  12. #212
    klw
    Guest
    Location
    , ,
    Member No: klw's Avatar


    Yes | No

    Re: hmmm.... logic flaw I think.

    The operating temp hypothesis was purely conjecture on my part for sure. This is a very interesting issue. It seems to me that the only facts we know are that the problem occurs on dual Vanos M52TU engines only and is best described as a bad idle/stall condition during warm-up on cold days. We also know that disconnecting the Vanos using a solenoid during initial warm-up, replacing the Vanos or even replacing the Vanos pistons fixes it. Finally, we know that subsequent 6 cylinder engine designs don't experience this problem even though their dual Vanos assemblies are identical. There are also subjective reports that performance gains occur when the Vanos is replaced, however these don't appear to be supported by empirical evidence.

    hmmm....

    I wonder if disassembled Vanos assemblies from subsequent engine designs also show the deterioration you noted in the seals.
    I agree that a startup algorythim DME invocation while the engine is warm would be a good test to perform.

  13. #213
    Registered Member
    Location
    Alameda, CA, United States
    Member No: 56621 tony540iA is an unknown quantity at this point tony540iA's Avatar
    Join Date
    Nov 2002
    Posts
    6,162
    Rep Power
    0


    Yes | No

    well, there's something else for me to check

    o-ring durometer is a function of temperature (among other things). So dropping one of the failed/aged/hardened o-rings in boiling water should soften it - also depends on what mechanisim is hardening the o-rings. Evaluating if this would be enough to allow the energizing o-ring to better seal the slide ring may be a little more difficult. I don't have a true durometer tester here, but may be able to come up with something.

    If I get a chance, I'll drop a whole unit, pistons and seals in boiling water, or hot oil, and try qualify if the pistons seal better at 200 deg F. Break out the turkey baster - This should get me some strange looks here at work.

    I too am curious if the newer motors/vanos units are any different, or if the fixes are purely software.

  14. #214
    abaroiant
    Guest
    Location
    , ,
    Member No: abaroiant's Avatar


    Yes | No

    Re: Thanks. Looking forward to results

    Got the Peake Research tool yesterday.

    The CEL was off, but it came back this morning after about 15 minutes of driving.

    checked the Error Codes and had the following:

    Table 15, Code 12 - Camshaft sensor - Exhaust Cam

    and

    Table 15, Code 92 - EVAP Capillary Leak (0.5mm)detected

    I cleared the error codes, and will keep recording them to see if the same ones return. I'll most likely replace the cam position sensor to see if it cures this specific problem. Then I'll focus on the EVAP leak.. as I have no idea where to start w/ that one...

    -A-

  15. #215
    Twobeemers
    Guest
    Location
    , ,
    Member No: Twobeemers's Avatar


    Yes | No

    What about dyno runs?

    What about using a car with the Vanos problem to make a couple baseline dyno runs, repairing or replacing the Vanos, and then repeating the dyno runs? Wouldn't that establish that cars without the properly functioning VANOS units did not perform as well as they do WITH a properly functioning VANOS unit?


  16. #216
    Twobeemers
    Guest
    Location
    , ,
    Member No: Twobeemers's Avatar


    Yes | No

    But isn't the VANOS still malfunctioning?

    You've used a timer to bypass the idle/stall symptom, but the real world functioning of the VANOS unit is still compromised. Isn't that the real issue, that the VANOS isn't VANOSing in our cars when we're running them hard?

  17. #217
    loach1
    Guest
    Location
    , ,
    Member No: loach1's Avatar


    Yes | No

    Yes, but no stalling!

    My car is a glorified grocery-getter, not an M5. It's a wagon and is really not very fast even with a new VANOS. The aggravation of my car stalling was the motivation to get it fixed, rather than missing any performance. I did not actually install the timer, but I conceived the idea to avoid having to change the VANOS, but my wonderful wife ponied up the money for a new VANOS so I fixed it properly.

  18. #218
    Registered Member
    Location
    , ,
    Member No: 63656 kwilcox is an unknown quantity at this point kwilcox's Avatar
    Join Date
    Jan 2003
    Posts
    10
    Rep Power
    0


    Yes | No

    not proven yet... (m)

    So far, the only empirical Vanos related evidence is the cold start failure. Complaint based evidence isn't pointing to other Vanos related issues such as emmissions problems, cat converter failures or performance degredation. Complaints can be considered empirical based on sheer volume. That's easy to see for the cold start issue but not at the same level for these other vanos related engine functions. It may well be that the solenoid workaround is as good a "fix" as the BMW engineers did (possibly with software) in later versions of the motor.

    If I still had my 2000 528i, I'd sure go for the solenoid "fix" over a $1000/yr vanos replacement...

    ... unless my catalytic converters started failing every year, or gas mileage dropped or engine performance decreased noticably or I started failing my smog tests....

  19. #219
    Registered Member
    Location
    , ,
    Member No: 63656 kwilcox is an unknown quantity at this point kwilcox's Avatar
    Join Date
    Jan 2003
    Posts
    10
    Rep Power
    0


    Yes | No

    This would provide good empirical evidence IMO


  20. #220
    Registered Member
    Location
    , ,
    Member No: 63656 kwilcox is an unknown quantity at this point kwilcox's Avatar
    Join Date
    Jan 2003
    Posts
    10
    Rep Power
    0


    Yes | No

    scratch vanos disconnect from known facts above


+ Reply to Thread
Page 11 of 18 FirstFirst ... 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 LastLast


Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum