+ Reply to Thread
Results 1 to 4 of 4
  1. #1
    Registered Member
    Location
    , ,
    Member No: 138001 DaneGuy is an unknown quantity at this point DaneGuy's Avatar
    Join Date
    Mar 2006
    Posts
    73
    Rep Power
    0


    Yes | No

    Help!! Dynamic Drive inactive!

    I just took off my 18" wheels and put on 19" take-offs from a 750. As soon as I went around a bend I got a warning that said Dynamic Drive was inactive and I was at a danger of rolling over. I'm not really worried about rolling over, LOL, but I am worried about that message.

    Is there something I need to do? Should I have taken it to the dealer to put the wheels on? How do I get rid of the error?

    All help and comfort highly appreciated.



  2. #2
    Registered Member
    Location
    BFE, BFE, United States
    Member No: 103164 GeezTech is an unknown quantity at this point GeezTech's Avatar
    Join Date
    Mar 2004
    Posts
    10,978
    Rep Power
    0


    Yes | No

    Check the fluid level for the power steering......

    .......if too low it can set off that warning. If low it takes a special fluid, Pentosin 11 S.
    Just changing wheels should cause that to happen, these cars aren't quite that sensitive, it was just a coincidence.


  3. #3
    Registered Member
    Location
    , ,
    Member No: 138001 DaneGuy is an unknown quantity at this point DaneGuy's Avatar
    Join Date
    Mar 2006
    Posts
    73
    Rep Power
    0


    Yes | No

    Weird. . . It just went away

    I took the car out again and this time there was no warning and all systems checked out OK. However, I will check the power steering fluid tomorrow. Thanks for the tip!

  4. #4
    Registered Member
    Location
    Hambuehren, , Germany
    Member No: 101305 Ekkehart is an unknown quantity at this point Ekkehart's Avatar
    Join Date
    Feb 2004
    Posts
    65
    Rep Power
    0


    Yes | No

    Re: known problem

    Should be an oil leak. Had the same problem on my 745i at about 65kmls. Indication went away when oil expanded (hot). A friendly dealer fixed the leaking gaskets to the oil cooler, steam cleaned the aerea, added 1/2l of Pentosin FOR FREE. The PUMA? system says the two hoses to the oil cooler should be replaced. About 200$ parts and labor.

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum