+ Reply to Thread
Results 1 to 10 of 10
  1. #1
    Registered Member
    Location
    , ,
    Member No: 113125 alanroseman is an unknown quantity at this point alanroseman's Avatar
    Join Date
    Sep 2004
    Posts
    16
    Rep Power
    0


    Yes | No

    Cruise not available, engine light, skipping

    Hello Folks,

    2003 X-Type sport, 2.5

    First cold snap in New England:
    Low temp warning -> crusie not available ->check engine light

    Engine begins to break down on acceleration. (like creep home mode)
    lasts for less than an hour. All return to nornal, just engine light remains on.

    Now even the engine light is back to normal. Any ideas?


  2. #2
    Registered Member
    Location
    Saint-Petersburg, , Russia
    Member No: 143138 Yurakli is an unknown quantity at this point Yurakli's Avatar
    Join Date
    Jul 2006
    Posts
    23
    Rep Power
    0


    Yes | No

    Re: Cruise not available, engine light, skipping

    I have same problem for about 3 months already. Since it started to be cold in Russia.
    All I can say this is electric problem, I’m sure. ECU reflash with new version helps. But in St. Petersburg, Russia no one from Jaguar dealers can do ECU flash. So I'm waiting for the weather warming up.

    If it helps you, please send me any kind scan of paper which you will get from you dealer, about what works with your Jag were done. I’d like to show it to my dealer, in order to prove my words about ECU reflash possibility.

    I asked Tim in this post with same problem
    http://forums.roadfly.com/forums/jaguar/jaguar_x_type/8216402-1.html
    but didn't get any information

  3. #3
    Registered Member
    Location
    , ,
    Member No: 113125 alanroseman is an unknown quantity at this point alanroseman's Avatar
    Join Date
    Sep 2004
    Posts
    16
    Rep Power
    0


    Yes | No

    Re: Cruise not available, engine light, skipping

    Yuri,

    I can only imagine the issues you face with a Jaguar in Russia. If I learn anyhting I'll be certain to fill you in.

    Cheers, Alan

  4. #4
    Bruce in canada
    Guest
    Location
    , ,
    Member No: Bruce in canada's Avatar


    Yes | No

    it is cold here but no problems

    It was -30 the other day .. and car started and ran with no issues..


  5. #5
    sender02
    Guest
    Location
    , ,
    Member No: sender02's Avatar


    Yes | No

    Re: Cruise not available, engine light, skipping

    I had the exact same problem here in upstate new york a few weeks back when it got down close to 0 degrees one night. The following morning, upon starting, I had the check engine light and the cruise control message flash. After that, the engine light stayed on. That was a Friday and didn't get to the dealer until Monday - drove it as little as possible over the weekend, but seemed to drive fine. The dealer reflashed the ECU (whatever that does) and the problem was solved. Its still been pretty cold (and snowy) and haven't had a problem since. I was also glad to learn from one of these posts that you can get rid of that annoying Low Temperature Warning by hitting the reset button after starting the car each time.

  6. #6
    Registered Member
    Location
    , ,
    Member No: 102475 scat is an unknown quantity at this point scat's Avatar
    Join Date
    Feb 2004
    Posts
    145
    Rep Power
    0


    Yes | No

    Re: Cruise not available, engine light, skipping

    Oxygen sensors and vacuum hose (had cracks) replaced at 60K miles for same symptoms, cost at dealer = $700

  7. #7
    Registered Member
    Location
    , ,
    Member No: 154255 Lenrapkins is an unknown quantity at this point Lenrapkins's Avatar
    Join Date
    Jun 2007
    Posts
    1
    Rep Power
    0


    Yes | No

    re xk8 engine skipping

    I have recently purchased a 97 xk8 with 78000 miles on the clock. Ater drivigg about 20 miles the engine starts skipping and the engine fault light comes on sometimes followed by the poor vehicle performance light. After leaving the car say overnight it again runs fine for another 20 miles or so and starts skipping again, has anyone had similar problems or any suggestions?

  8. #8
    Ralph Simpson
    Guest
    Location
    , ,
    Member No: Ralph Simpson's Avatar


    Yes | No

    Re: Cruise not available, engine light, skipping

    I posted this response in another area of this forum, but now read this problem which exactly matched mine.

    Thanks to all who wrote about the PVC hose. I am the original owner of a 2002 X-Type 3.0 with automatic. This weekend the engine light went on with a warning message that the cruise control is unavailable. The cruise worked and the only symptom I noticed was a slight lurching when slowing to a stop. I found these posts about the PVC hose and checked out mine to find there was a 4 inch slit in this hose. I bought a replacement from the dealer ($20) and noticed the new one has a waffle texture instead of smooth and feels stiffer. It also has clamps on each end which were missing on the original. This fixed the problem! It drives smoother and there is absolutely no lurching as I come to a stop.

    The work involved is to take off the 3 screws and the oil filler cap which holds the plastic cover over the engine. Then remove the old hose by hand, reinstall the new hose with the 2 crimp style clamps. This hose is about 10 inches long and 1 inch in diameter going from the exhaust manifold to the engine, entering the engine right next to the rightmost screw anchor holding the plastic cover. Replace plastic cover and you are done (about 10 minutes). I recommend this as good preventive maintenance for anyone who still has the old smooth PVC hose.

  9. #9
    Registered Member
    Location
    , ,
    Member No: 180302 tylersdad513 is an unknown quantity at this point tylersdad513's Avatar
    Join Date
    Mar 2010
    Posts
    1
    Rep Power
    0


    Yes | No

    Re: Cruise not available, engine light, skipping

    I have the same problem with my 2003 Jaguar X Type. Do you have the part number for this hose so it will make it easier to locate it at a local dealer. Sounds like and easy enough fix.

  10. #10
    User Level 1
    Location
    Chicago, , USA
    Member No: 197294 RST13 is an unknown quantity at this point RST13's Avatar
    Join Date
    Jan 2013
    Posts
    1
    Rep Power
    0


    Yes | No
    Jaguar X-Type AWD 2.5

    Sometimes those lights would come up even when its not that cold outside
    But today temperatures went down to -18 Celsius here in Chicago and of course my check engine light and cruise not available came up (again)

    Somehow it goes away after a couple of days, I wasn't really following temperatures but now I see, cold is a factor to it.

    I am definitely going to try replacing PVC hose
    Even know when Cruise Not Available and Check Engine lights come up, car drives just fine and even Cruise is working-I dont really feel any difference in driving
    But it bothers me a Lot..... I hate those Check engine lights

    Will ECU Flash help?
    Or replacing PVC does the job?
    Or do I need to do Both?
    Thanks 4 advise
    Last edited by RST13; 01-22-2013 at 10:59 AM.
    Reply With Quote Reply With Quote 66.239.124.230

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum