+ Reply to Thread
Results 1 to 8 of 8
  1. #1
    Registered Member
    Location
    San Ramon, CA, United States
    Member No: 127514 BrianINSF is an unknown quantity at this point BrianINSF's Avatar
    Join Date
    Jun 2005
    Posts
    43
    Rep Power
    0


    Yes | No

    Service Info Screen "Data Transmission Fault "

    Help. I have this message on my 05 645ci when I go into the display -- Service / Service Information screen: Data transmission fault 01/05/2007 10:53:05. I don't recall seeing this message on here until after the transmission "banged" like I was rear-ended when approaching a stop light this past weekend. I'm on CIP 22.x

    I took it to the dealer and they stated on the repair order "Most Bus faulted performed test module for faults (not present - target configuration is incorrect. Performed configuration registry and cleared fault memorys per test module - rechecked operation and check control messages - ok"

    When I go pick up my car the message is still there, yet they repaired/replaced somthing! They inform me that the message means nothing, its just a "log message". I ask them to remove it and they say they can't its the way it is." I inform them to reload the sofware and they tell me they can't do it without BMW/NA permission. Now I don't like errors, being a computer geek. Is this true and is there something else I can do?

    '05 645ci, Mineral Silver Metallic/Cream Beigh Dakota Leather/Ruthenium Pearl Gloss Wood Trim, Cold Weather Pkg, Premium Audio Sound Pkg(Logic7), Sport Pkg, 6-speed Steptronic, Sirius Satellite Radio, Tinted windows, Star Spoke (Style #92),Hardwired Bell Pro RX65 Radar,T-mobile MDA BT/WiFi/PPC/Phone, custom sheep skin seat covers; Top speed 151mph <--handled like driving at 40mph :)!!


  2. #2
    Registered Member
    Location
    BFE, BFE, United States
    Member No: 103164 GeezTech is an unknown quantity at this point GeezTech's Avatar
    Join Date
    Mar 2004
    Posts
    10,978
    Rep Power
    0


    Yes | No

    Find a new dealer.................................

    ...Does the message look like DOS print?

    You are already used to the car, and you know it shouldn't be like that, just take them to any car on the lot and show them they are wrong.

    The can easily get approval to load software, they just need to put out some effort and creat a PuMA case, they will probably direct them to try software first and if that doesn't fix it then they will replace components.

    The MOST bus configuration problem was probably because a tech didn't disconnect the fiber optic cable after programming when prompted to do so and the BMW test equipment used was stored in the system, very common issue when the tech doesn't pay attention to things.

    But, it wont hurt a thing and it is "invisable" to the customer as it doesn't cause any problems or make any warning lights come on.

    I would take it back in to them and if they wont do anything then get customer service involved, that isn't right, they are just blowing you off.

    Can you post a picture of the message or e-mail it to me?



  3. #3
    Registered Member
    Location
    , ,
    Member No: 15919 Ginger is an unknown quantity at this point Ginger's Avatar
    Join Date
    Oct 2001
    Posts
    4,353
    Rep Power
    0


    Yes | No

    Re: Service Info Screen Data Transmission Fault

    I'm with BMW of North America, LLC. I've passed this message on to a BMW NA Customer Relations Representative who will be in touch with you soon.

  4. #4
    Registered Member
    Location
    , ,
    Member No: 32350 destro is an unknown quantity at this point destro's Avatar
    Join Date
    Apr 2002
    Posts
    104
    Rep Power
    0


    Yes | No

    I have a 2005 645 with SAME problems!!

    send me an email antonio3 @ gmail . com i have all the SIB's and Puma cases to fix this... There is a special Laptop that has to be brought in for your car!!! This is a "common" problem with some 2005 bmw's, common meaning they know enough about it to have a special laptop to fix it.


  5. #5
    Registered Member
    Location
    , ,
    Member No: 32350 destro is an unknown quantity at this point destro's Avatar
    Join Date
    Apr 2002
    Posts
    104
    Rep Power
    0


    Yes | No

    Oh yea

    If the dealer didn't clear that message.. then they didn't touch the car and probably had BMWNA send them a check.

    Send me an email.

    Currently they are on version 25 of the software.

  6. #6
    Registered Member
    Location
    BFE, BFE, United States
    Member No: 103164 GeezTech is an unknown quantity at this point GeezTech's Avatar
    Join Date
    Mar 2004
    Posts
    10,978
    Rep Power
    0


    Yes | No

    V25 probably fixes it, dealer needs to wake up

    Don't argue with idiots, they'll drag you down to their level and beat you with experience.

    Find the problem first! Dont spend $$$$$ on parts you may not need.

    '87 325is The best ever
    '76 2002 The worst ever
    ALUMINUM BUMPER APPRECIATION ASSOCIATION (ABAA)
    Membership ID (00302)
    Joined September 14, 2005

    The secret to my success

  7. #7
    Registered Member
    Location
    San Ramon, CA, United States
    Member No: 127514 BrianINSF is an unknown quantity at this point BrianINSF's Avatar
    Join Date
    Jun 2005
    Posts
    43
    Rep Power
    0


    Yes | No

    Re: FOLLOW UP - Svce Info Screen Data Trans Fault

    Thanks everyone for all your suggestions. I took the car to another dealer and after leaving it with them for 2 days the problem was resolved by them reporting the following: "14571 TCU needs to be deactivate check the number for the TCU and re-enter numbers and warning went away. Next morning started vehicle and warning came back. Wrote to puma per puma if vehicle has account is not active, deactivate the TCU....Hook up SSS tester with version 25.02 found vehicle needs updating. Performed deactivate of the TCU."

    With this fix, I was able to get up to version 25.02 via the warranty work. I've noticed that my voice commands are now more accurate, the display colors match my interior, the annoying lawyer screen automatically disappears and the car is much more responsive (could be my happier attitude). Overall, I'm BACK to being very satisified with BMW, the new service dealer and the 6! Thank you BMW for meeting my expectations.

    '05 645ci, Mineral Silver Metallic/Cream Beigh Dakota Leather/Ruthenium Pearl Gloss Wood Trim, Cold Weather Pkg, Premium Audio Sound Pkg(Logic7), Sport Pkg, 6-speed Steptronic, Sirius Satellite Radio, Tinted windows, Star Spoke (Style #92),Hardwired Bell Pro RX65 Radar,T-mobile MDA BT/WiFi/PPC/Phone, custom sheep skin seat covers; Top speed 151mph <--handled like driving at 40mph :)!!

  8. #8
    Registered Member
    Location
    Titusville, FL, United States
    Member No: 107311 cobradav is an unknown quantity at this point cobradav's Avatar
    Join Date
    May 2004
    Posts
    1,221
    Rep Power
    0


    Yes | No

    Re: FOLLOW UP - Svce Info Screen Data Trans Fault

    Thanks for the follow up. I forgot about the TCU potential. There have to be at least 1/2 dozen service bulletins on TCUs - not programed - accidently reset - I think the symptoms vary, but do not remember ever seeing your Fault listed as an indicator. I will now.
    _______
    US '05 645 Coupe, Silver Grey, Chateau, Sport, Logic 7, HUD, Cold Pkg, SIRIUS Sat Radio, Aux, BT w/ snap-in adapter, V1, CIP 21.03 w/MP3 enabled

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum