+ Reply to Thread
Results 1 to 2 of 2

Hybrid View

  1. #1
    Registered Member
    Location
    , , United States
    Member No: 120997 jemarin is an unknown quantity at this point jemarin's Avatar
    Join Date
    Feb 2005
    Posts
    9
    Rep Power
    0


    Yes | No

    Electric water pump problem?

    There is a noise coming from near the bottom of the radiator on the driver's side. It's a whirring sound like a bearing is going out on an electric motor. I believe it's the electric water pump that pushes water through the heater core because it only makes the noise when the heater is on. If I set the climate control to 60 there is no sound. The moment I turn it up the sound comes back.

    Anyone ever have trouble with this or ever replace this part? #2 in the link below.

    Would air in the system cause it to sound like that? I don't have any overheating issues at all so I don't know if it could be air in the cooling system.

    The car is a 99 528i with 179K.

    http://www.realoem.com/bmw/showparts...30&hg=64&fg=18Anaheim Hills, CA
    '99 528i Sport, Black/black

  2. #2
    Registered Member
    Location
    , ,
    Member No: 13750 srford is an unknown quantity at this point srford's Avatar
    Join Date
    Sep 2001
    Posts
    321
    Rep Power
    0


    Yes | No

    most of us wouldn't know since....

    we do not drive/own your vehicle.....(this is a different board)
    Try the E39 board

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum