+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 21 to 28 of 28
  1. #21
    Roman
    Guest
    Location
    , ,
    Member No: Roman's Avatar


    Yes | No

    Re: 04 Z4 Won't Start

    I had a same problem an hour ago.This is what I did: I turned off my front lights and my cabin light.Then turned the ignition key and after 3-4 seconds of jumping and growling my Z4 came back to life.


  2. #22
    Registered Member
    Location
    , ,
    Member No: 116978 Z-4CE is an unknown quantity at this point Z-4CE's Avatar
    Join Date
    Nov 2004
    Posts
    113
    Rep Power
    0


    Yes | No

    Re: 04 Z4 Won't Start

    I had the same problem and replaced my battery, works great now! When I looked at the battery, the status indicator was green, in other words don't trust it!
    2003 3.0 Sterling gray, black leather, 6 speed manual.
    Hardtop for the winter, Sport, Convenience and Premium packages, Xenon, Hoen H11 driving lights, CDV delete, Alutec and ACS strut bars,Goodyear Eagle F1 GS-D3's.
    Dinan stage III software, High flow throttle body, High flow intake, Ram air intake duct, Free flow exhaust.

  3. #23
    Bad Email Address on File
    Location
    , ,
    Member No: 84505 Penguin is an unknown quantity at this point Penguin's Avatar
    Join Date
    Aug 2003
    Posts
    1,723
    Rep Power
    0


    Yes | No

    Re: 04 Z4 Won't Start

    The "Magic Eye" status indicator on auto batteries only shows the condition of one of the six cells, i.e., it assumes all six cells deteriorate at the same rate. My experience is that a battery reaches the end of it's useful life as a result of one or two cells deteriorating much more than the others.

    The best test is a load test, but the easiest is to measure the terminal voltage after the vehicle has sat with the engine off overnight, and then to measure the battery voltage with the headlights on and the engine off.

    A google for "auto battery voltage test" will give details of how to interpret the results.

  4. #24
    Unregistered
    Guest
    Location
    , ,
    Member No: Unregistered's Avatar


    Yes | No

    Z4 not starting issue

    have the key tested. the dealership replaced my starter and 3 days later same issue as before, they ordered a new key because the old one was not charging anymore or rather would not stay charged long enough to hold the car data and would no longer start the car.
    Reply With Quote Reply With Quote 71.21.180.253

  5. #25
    Registered Member
    Location
    , ,
    Member No: 12416 ZeattleDave2002 is an unknown quantity at this point ZeattleDave2002's Avatar
    Join Date
    Aug 2001
    Posts
    7,956
    Rep Power
    0


    Yes | No
    Goddammit people - the thread is FIVE years old and he probably started his car by now and doesn't need any advice :/
    Reply With Quote Reply With Quote 98.247.65.79

  6. #26
    Unregistered
    Guest
    Location
    , ,
    Member No: Unregistered's Avatar


    Yes | No

    brand new battery but same problem

    2003 Z4, had just replaced the battery 1.5 weeks ago, car sat for about a week, bad rain storms the past 2 days. Now car won't start, no indicator lights come on, multiple clicking heard from engine, window keeps coming down a little each time and clicking heard from door (window motor). And trunk light and top indicator lights flashing when have key in the ignition. Tried to jump and those same lights just flashed more.
    Reply With Quote Reply With Quote 99.43.189.90

  7. #27
    Unregistered
    Guest
    Location
    , ,
    Member No: Unregistered's Avatar


    Yes | No

    5 years

    Quote Originally Posted by ZeattleDave2002 View Post
    Goddammit people - the thread is FIVE years old and he probably started his car by now and doesn't need any advice :/
    Mostly, having these threads be active helps those of us who experience the same problems. Like me. Today.

    My 2003 Z3 will not turn over. Dash is lit. Lights work. Past experience tells me battery or starter.

    Not sure if the lights dim when i engage the starter. This thread has me looking at the battery, battery connection, neutral safety switch, starter connection. And the key, which I did not know could cause this, but I'll try my spare just in case.

    So, ignore the complaint about the age of the forum post and keep providing possible causes, thanks.
    Reply With Quote Reply With Quote 137.95.1.4

  8. #28
    User Level 1
    Location
    , ,
    Member No: 199422 Taschneider is an unknown quantity at this point Taschneider's Avatar
    Join Date
    Oct 2013
    Posts
    3
    Rep Power
    0


    Yes | No
    Have 2005 Z4 will not startLights do not dim battery reads 12.5 voltsHear clicking starter does not do anything13,000 miles on car
    Reply With Quote Reply With Quote 70.211.10.209

+ Reply to Thread
Page 2 of 2 FirstFirst 1 2


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum