+ Reply to Thread
Results 1 to 9 of 9
  1. #1
    Ian Clancy
    Guest
    Location
    , ,
    Member No: Ian Clancy's Avatar


    Yes | No

    sluggish 535i?

    Just bought a 1986 535i with an automatic transmission. What a letdown! I know this model came with an EF transmission that works similar to a CVT. From a standing start this car is a dog. My 78 320i would smoke it from 0-30 mph. There is also no "kickdown" feature, further making the car feel slower. the car simply surges forward with no gear changes. Is this normal? I'm not a fan of automatics and this just reinforces it. On the highway however this car really screws. 60-90mph in no time flat. Around town this car can't even get out of its own way....please tell me this is normal for an auto 535i ! Thank you.

    78 320i
    85 323i
    86 535i



  2. #2
    Registered Member
    Location
    Indianapolis, IN, United States
    Member No: 112258 cwdunlap is an unknown quantity at this point cwdunlap's Avatar
    Join Date
    Aug 2004
    Posts
    110
    Rep Power
    0


    Yes | No

    That's not right

    I've driven some autos and that does not sound even close to right. Maybe you need it checked out.

    Chris
    85 M635
    83 533 (seen better days)


  3. #3
    TJ
    Guest
    Location
    , ,
    Member No: TJ's Avatar


    Yes | No

    sounds like the "limp home mode"

    While a 535i w/ 4-speed automatic isn't known for quickness off the line, if it was working right you would definitely notice it changing gears. The transmission controller has a limp mode where it stays in third gear only. I don't remember what causes it but you should be able to find it by searching the forum archives.

  4. #4
    ian
    Guest
    Location
    , ,
    Member No: ian's Avatar


    Yes | No

    Re: That's not right

    I had a feeling something was wrong. Its just did not seem right. Is this an easy fix, or do I need a new transmission?

  5. #5
    Ray7er6ers5er3er
    Guest
    Location
    , ,
    Member No: Ray7er6ers5er3er's Avatar


    Yes | No

    Have U checked the fluid level? That's 1st..


  6. #6
    Ray7er6ers5er3er
    Guest
    Location
    , ,
    Member No: Ray7er6ers5er3er's Avatar


    Yes | No

    Try shifting manually to get what it really should

    feel like. Chances are you got a car that has been poorly maintained and will now have to play catch up. I've got both a 5 spd and an automatic and though they are not 'quick' they are fast.

  7. #7
    ian
    Guest
    Location
    , ,
    Member No: ian's Avatar


    Yes | No

    Re: Try shifting manually to get what it really sh

    "manually" does not work either. Strictly just 3rd gear. E,S, don't function either.

  8. #8
    Joe in NJ
    Guest
    Location
    , ,
    Member No: Joe in NJ's Avatar


    Yes | No

    Re: Try shifting manually to get what it really sh

    How many miles? Sounds like a good time to do a 5 speed swap. Did you test drive it before you bought? Did you have a BMW Tech look it over before you bought.

  9. #9
    Registered Member
    Location
    , ,
    Member No: 163215 bmwknowitall is an unknown quantity at this point bmwknowitall's Avatar
    Join Date
    Mar 2008
    Posts
    11
    Rep Power
    0


    Yes | No

    Re: sluggish 535i?

    When your in the car turn the key on till the dash lights come on or start the car. Pull the shifter all the way down to 1st slowly and watch the dash light indicators as to what gear your in. Other than D that commonly burnt out all the lights should work. If you don't see the lights working right or no 321 lights then your shifter position sensor is bad and its not telling the computer what gear you want SO the computer is going into (at least I can get you home mode) in 3rd grear only. This is the most common problem.
    Try unhooking the S E 321 switch and then see if it starts working right. If the s e 321 switch is bad unplugging it will give a "e" signal to the computer.
    There is a warning light that looks like a little gear that light mostly comes on when the transmission does not pass the quick selinoid test IF that light stays on after you started the car the transmission is likely junk. Problems with the trans computer is extrememly rare and you should not worry about it.

    Its a GOOD thing NOT to see the gear light after you start the car. Then its a very good chance its just the shift lever sensor.

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum