+ Reply to Thread
Results 1 to 3 of 3
  1. #1
    lyonsfin
    Guest
    Location
    , ,
    Member No: lyonsfin's Avatar


    Yes | No

    S500 AC Issue

    My AC is not working. It is charged and I assume the compressor is OK as it does hold the charge, but the compressor does not come on. I am thinking it is some type of electronic control malfunction. Any ideas?
    Thanks.

    Josh


  2. #2
    Just Me
    Guest
    Location
    , ,
    Member No: Just Me's Avatar


    Yes | No

    Re: S500 AC Issue

    Generally speaking the compressor will not come on for 2 primary reasons: 1. Not enough charge ro 2. Bad compressor. Hopefully your evaporator core has already been replaced, that's an expensive fix!

  3. #3
    Registered Member
    Location
    , ,
    Member No: 143351 boentgru is an unknown quantity at this point boentgru's Avatar
    Join Date
    Jul 2006
    Posts
    11
    Rep Power
    0


    Yes | No

    Re: S500 AC Issue

    A common and well known deficiency on the W140 A/C is evaporator (the cooling heat exchanger under the dashboard) which is prone to developing leaks. Although this item has no moving parts, it deveops leaks due to defective deign or material choice. Although this is well known, MB assumes no responsibility for it. Furthermore, due to the design, it is expensive (many man-hours) to replace since much of the dashboard needs to be desmantled. Sorry for the bad news.

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum