+ Reply to Thread
Results 1 to 6 of 6
  1. #1
    Roemhildt
    Guest
    Location
    , ,
    Member No: Roemhildt's Avatar


    Yes | No

    1988 735i blower problems despite replaced sword

    Greeings

    I recently began experiencing the same blower symptoms I did when I first bought my '88 735i in 2000. They were basically a blower with a "mind of its own" that came on when it felt like it regardless of control settings. The only way to have constant air movement was to turn the control wheel to full on. I replaced the sword at that time and all was fine for nearly 8 years until recently, when the same symptoms returned. I guessed that the cause of my recent troubles with the same as it was 8 years ago so I ordered up a rebuilt (by Programa) sword from BMA and installed it.

    The blower worked as it should for all of 10 minutes and then suddenly started acting badly again. When it "decides" to come on, it usually comes on at only a medium speed regardless of control wheel settings. Sometimes it comes on when the wheel is set to full OFF, again at a medium speed. After those first 10 minutes of bliss, there is no longer any variable control and the fan once again has a mind of its own.

    Any ideas??!!

    Thanks

    Mike Roemhildgt
    1988 735i 234k


  2. #2
    klancf51
    Guest
    Location
    , ,
    Member No: klancf51's Avatar


    Yes | No

    Re: 1988 735i blower problems despite replaced swo

    Mike,
    See my post on
    Blower motor in the archives. Good luck.

    klancf51
    1988 735i 132K

  3. #3
    Roemhildt
    Guest
    Location
    , ,
    Member No: Roemhildt's Avatar


    Yes | No

    Re: 1988 735i blower problems despite replaced swo

    Hi

    Thanks! I will try as you suggest, but the blower motor is less than two years old. I would hope it would last longer than that!

    Mike

  4. #4
    Registered Member
    Location
    , ,
    Member No: 14327 Highline is an unknown quantity at this point Highline's Avatar
    Join Date
    Oct 2001
    Posts
    2,155
    Rep Power
    0


    Yes | No

    Why do you not send it back to BMA?

    Maybe the reman sword from Programa is again defective, can happen. I heard that once before on another E32 board, BB.
    At least they shoould check it and confirm that it works.
    Usually the brushes on a motor last for many years, on my car still the first motor is inside without any repair/new brushes, almost 20 years now.Shogun's E32 Tech Tips: http://tridem.han-solo.net/auto/erich/auto.htm

  5. #5
    Roemhildt
    Guest
    Location
    , ,
    Member No: Roemhildt's Avatar


    Yes | No

    Re: Why do you not send it back to BMA?

    Yes, that seems obvious. On the other hand, Electronics are generally not returnable unless defective, so I'd like to be more certain the sword's defective before returning it.

    Thanks

    Mike

  6. #6
    Roemhildt
    Guest
    Location
    , ,
    Member No: Roemhildt's Avatar


    Yes | No

    Re: 1988 735i blower problems despite replaced swo

    I've tried to jar the blower into working a few times now, but with luck only once (which could also have been coincidence).

    Often the fan will run when the wheel is turned to 0 (off). From what I've read so far, this would most likely implicate the sword.

    Is it possible the problem could be in the IHKA control unit behind the sword?

    Mike

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum