+ Reply to Thread
Results 1 to 6 of 6
  1. #1
    Registered Member
    Location
    Auckland, AK, New Zealand
    Member No: 167977 AssetMan is an unknown quantity at this point AssetMan's Avatar
    Join Date
    Sep 2008
    Posts
    2
    Rep Power
    0


    1 out of 1 members found this post helpful. Yes | No

    E66 Parking Brake failure

    I have an 02 E66 745 where the parking brake will work only intermittently and then, only when the car is just moving, in DRIVE, and never works when the car is stopped.
    The yellow parking brake light is on all of the time, and changes to red, only when the park brake finally decides to work.
    Then, when I turn the ignition off, the parking brake turns off as well, leaving the transmission to hold the car.
    Because the mechanics still work, this clearly seems to be a sensor issue. All I need is some help to point me towards which one.


  2. #2
    Registered Member
    Location
    BFE, BFE, United States
    Member No: 103164 GeezTech is an unknown quantity at this point GeezTech's Avatar
    Join Date
    Mar 2004
    Posts
    10,978
    Rep Power
    0


    1 out of 1 members found this post helpful. Yes | No

    Re: E66 Parking Brake failure

    You probably have a broken cable and this why the yellow and red light are coming on.
    It is just a guess but you should take it in and have it looked at.

  3. #3
    Registered Member
    Location
    Auckland, AK, New Zealand
    Member No: 167977 AssetMan is an unknown quantity at this point AssetMan's Avatar
    Join Date
    Sep 2008
    Posts
    2
    Rep Power
    0


    Yes | No

    Re: E66 Parking Brake failure

    Thanks. We have checked this and seems OK. Also, the brake works, all be it intermittently, therefore I assumed that mechanically it is OK.

    I have already "taken it in" 3 times and we are getting nowhere, but at least I haven't had a bill yet. It is "in" again at the moment, and he is checking all sensor faults through the diagnostics business.

  4. #4
    Registered Member
    Location
    Long Beach, CA, United States
    Member No: 132686 jacks25 is an unknown quantity at this point jacks25's Avatar
    Join Date
    Oct 2005
    Posts
    10
    Rep Power
    0


    Yes | No

    Re: E66 Parking Brake failure

    My parking brake malfunction light keeps coming on. Strangely; if you pop the trunk from the inside and then hit the parking brake button again; it goes off - until the car is put into 'drive'. Then it comes back on.
    Clearly a sensor issue. Can anyone tell me if replacing the sensor is a DYI job?
    Thanks

  5. #5
    Unregistered
    Guest
    Location
    , ,
    Member No: Unregistered's Avatar


    Yes | No

    parking brake light

    Parking brake actuator. That happened in my 05 745Li Very common because the gears are plastic and do break
    Reply With Quote Reply With Quote 99.189.216.247

  6. #6
    2007e65
    Guest
    Location
    , ,
    Member No: 2007e65's Avatar


    Yes | No

    2007 E65 parking break working only when car is on driving, wont engage when on park

    2007 E65 parking break working only when car is on driving, wont engage when on park. Sometimes light will go away when i disconnect parking brake unit.
    Brake didnt work at all and i just changed broken plastic gear, mechanism seems to work fine i used instructions from youtube videos and like i said it works while driving.
    Any suggestions , i heard it could be sensor, anybody knows where is located? Thanks
    Reply With Quote Reply With Quote 108.162.212.125

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum