+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 20 of 31
  1. #1
    Registered Member
    Location
    , ,
    Member No: 130869 waldoman is an unknown quantity at this point waldoman's Avatar
    Join Date
    Sep 2005
    Posts
    2
    Rep Power
    0


    Yes | No

    ABS, 4x4, and Brake warning lights all on...

    Yesterday morning I had the rear brakes rebuilt (rotors, pads, and all) at the local BMW dealer. That afternoon, my wife was driving the car and when attempting to park in a perpendicular parking space, she felt significant drag from the rear wheels (as if she was running up over a curb) and then ABS, BRAKE, and 4x4 lights all illuminated! She checked the hand brake (no problem) and for a curb (none there).

    She called the dealer at once, who recommended having the car towed in. Once at the dealer, the alarm lights were no longer lit and there was no problem! They connected the X3 to the diagnostic computer and found NO RECORD of the alarm.

    I am highly suspicious that the brake work was somehow involved with the alarm.

    Their claim: the alarm is in no way connected to the brake work (and that we owe them for the tow).

    Any ideas?

    ++ Peter
    E83, 65k mi


  2. #2
    Registered Member
    Location
    , ,
    Member No: 169090 macnut is an unknown quantity at this point macnut's Avatar
    Join Date
    Oct 2008
    Posts
    10
    Rep Power
    0


    Yes | No

    Re: ABS, 4x4, and Brake warning lights all on...

    From posts on other boards, those 3 lights coming on together can be caused by quite a few different things detected by the speed sensors on the wheels (some quite innocuous - like incorrect sized tires). If it was just the lights coming on temporarily, road debris on the speed sensors, or the beginning of sensor failure, would be one of the first things to rule out. I imagine a sensor could have been unwittingly damaged during the brake work. However, the sudden drag on the rear wheels suggests something else involved.
    There have been a few reports of differential failure symptoms on early X3s, but noise would be expected first. Similarly for a wheel bearing about to fail.
    I have read that the ABS and 4x4 lights going are typically not recorded as an OBDII code, and this may apply to the dealer's expensive diagnostic computer too - it just analyzes what is captured in much greater detail.
    Can't think of anything a qualified BMW technician would do wrong on a routine brake job that would cause those symptoms, but as you say, the finger of suspicion logically points in that direction.
    Seems like you will have to eat the tow bill for now at least, wait for further symptoms, and judge whether it is feasible to drive straight to the dealers with the lights still on.


  3. #3
    Registered Member
    Location
    , ,
    Member No: 169090 macnut is an unknown quantity at this point macnut's Avatar
    Join Date
    Oct 2008
    Posts
    10
    Rep Power
    0


    Yes | No

    Re: ABS, 4x4, and Brake warning lights all on...

    One more thing ..... just found this post which may be relevant:


  4. #4
    Registered Member
    Location
    , ,
    Member No: 130869 waldoman is an unknown quantity at this point waldoman's Avatar
    Join Date
    Sep 2005
    Posts
    2
    Rep Power
    0


    Yes | No

    Re: ABS, 4x4, and Brake warning lights all on...

    macnut, thanks for your response. It happened once more, but this time it was lights only with no discernible drag. I took it to the dealer with the alarms still on and this time it did record with an OBDII code. They said it was an electro-mechanical part associated with the transfer case. ?? It's also a part that they've never had to replace and have never even ordered the part. Unless it's been damaged (and this car's never been ridden hard), if this part is truly at fault, then with just 65K on the car, i think that this would be a case for it being damaged during the brake work, or just a faulty part from the getgo.

    The alarms haven't reappeared, so I may ignore it for now. Oh yes, they said the cost to replace the part is $1,400!

    ++ Peter

  5. #5
    macnut
    Guest
    Location
    , ,
    Member No: macnut's Avatar


    Yes | No

    Re: ABS, 4x4, and Brake warning lights all on...

    Just had a look at the transfer case on realoem. Maybe the actuator (no. 12)?

    http://www.realoem.com/bmw/showparts...27&hg=27&fg=15

    Not sure if it would be exposed to damage during a brake job. Doesn't show a price for the part unfortunately - maybe because it is not frequently ordered. Probably about $1,000 at a guess, and 4 hours labor to R & R.

    Worth trying for a goodwill warranty extension through the dealer, particularly if they feel a bit obligated to you after the profitable brake job!

  6. #6
    Registered Member
    Location
    , ,
    Member No: 169379 Wheezer is an unknown quantity at this point Wheezer's Avatar
    Join Date
    Nov 2008
    Posts
    1
    Rep Power
    0


    Yes | No

    Re: ABS, 4x4, and Brake warning lights all on...

    Having same problem with my 2005 X3 +/- 48,000 miles . Same warning lights & symptoms. My service manager says bad Transfer Case actuator. Covered under warranty, but it's going to take a week to get parts & install.

  7. #7
    Registered Member
    Location
    , ,
    Member No: 169090 macnut is an unknown quantity at this point macnut's Avatar
    Join Date
    Oct 2008
    Posts
    10
    Rep Power
    0


    Yes | No

    Re: ABS, 4x4, and Brake warning lights all on...

    Phew! Good thing you are still 2k miles inside warranty to smooth the replacement process. When you get it done next week, please post what would have been the cost if that shows on your invoice (some do and some don't).

  8. #8
    Registered Member
    Location
    , ,
    Member No: 172894 peekat88 is an unknown quantity at this point peekat88's Avatar
    Join Date
    Apr 2009
    Posts
    1
    Rep Power
    0


    Yes | No

    Re: ABS, 4x4, and Brake warning lights all on...

    I also had this problem come up. I'm not sure if its coincidence or not, but it happened shortly after i got a brake fluid change by a mechanic (not the dealer).
    I brought it to the dealer after and they said it was likely a bad servomotor which the repair would be $800 for the part and about 2.5-3 hours of labor @ $175/hr.

    I'm wondering if it could be a sensor that got damaged during the brake flush instead of an actual bad part. Does the process of changing the brake fluid affect the sensors near the ABS or servomotor?

    thanks
    peekat88

  9. #9
    Registered Member
    Location
    , ,
    Member No: 173297 klyomama is an unknown quantity at this point klyomama's Avatar
    Join Date
    Apr 2009
    Posts
    2
    Rep Power
    0


    Yes | No

    Re: ABS, 4x4, and Brake warning lights all on...

    Hello,

    Just wondering if your X3 problem was resolved. I have an 05 X3 with 57000 miles on it. And it is having the exact same problem. I am ready to get rid of the car if it is really a transfer case problem.

    Thanks

  10. #10
    Tonys
    Guest
    Location
    , ,
    Member No: Tonys's Avatar


    Yes | No

    Re: ABS, 4x4, and Brake warning lights all on...

    I had this exact same problem. All three lights and significant drag on the rear wheels just before coming to a stop. Did it all the way home (5 miles) one Friday night. I went out Saturday morning to see if I could figure out what was wrong with it and it was fine. 4 months and the problem has not returned. This happened when I had about 85,000 miles on it. Over 90k now.
    related note: I replaced all the fluids in the vehicle including the transfer case at about 75,000 miles. Later I discovered it was somewhat questionable to replace the auto tranny fluid. I wonder if this applies to the transfer case as well.

  11. #11
    Me
    Guest
    Location
    , ,
    Member No: Me's Avatar


    Yes | No

    Re: ABS, 4x4, and Brake warning lights all on...

    Guys, I just posted on the URL mentioned previously....new transfer box needed.... not happy ...whatever posessed BMW to build something so complex to do 4 wheel drive ? should ahve stuck to building 5 Series.


  12. #12
    mmddmm
    Guest
    Location
    , ,
    Member No: mmddmm's Avatar


    Yes | No

    Same issue

    I purchased my 2005 X3 used 2 years ago with 67K miles on it. I now have 90K miles. No serious issues with the vehicle.

    Last night I tried to accelerate from a stop light and the "BRAKE" lamp (yellow) and the 4x4 lamp came on. It felt like I was flooding a manual transmission engine while creeping through the intersection. Minimal power was delivered in pulses...like pumping the brakes while pushing lightly on the gas...or so it felt.

    I pulled onto a shoulder, shut the car off and read through the owners manual. When I restarted the car the lamps were out and the car drove normally. Went to work today and it is still working normally.

    Debating whether to take it to the dealer. Seems the more people start poking around to find a problem, the more problems you get. I'll need to see if the TCA would be covered on my extended warranty, but I'm guessing it's not.
    Reply With Quote Reply With Quote 74.84.108.185

  13. #13
    Unregistered
    Guest
    Location
    , ,
    Member No: Unregistered's Avatar


    Yes | No

    Getting screwed with BMW X5 2005 4 X 4 actuator

    I took out exended warrantee with company called aul had to do 4 X 4 Coverage and they did not cover anthing
    about the 4 X 4 actualtor e care ful what you sign on for or you can get royally screwed.
    Reply With Quote Reply With Quote 68.105.55.226

  14. #14
    Unregistered
    Guest
    Location
    , ,
    Member No: Unregistered's Avatar


    Yes | No
    The exact same thing happened to my 2008 x3. The light's go on, then ill drive for awhile and then they'll go off, repeating cycle.
    Reply With Quote Reply With Quote 184.2.78.139

  15. #15
    User Level 1
    Location
    , ,
    Member No: 189968 bgkm is an unknown quantity at this point bgkm's Avatar
    Join Date
    Jan 2012
    Posts
    3
    Rep Power
    0


    Yes | No

    ABS 44 and brake light

    The same happened on my 328xi, got the brakes done and the 3 lights (abs, 4 x 4 and brake) started going on intermittently. Phoned the dealer and they said that could happen with a weak battery, try trickle charging it. Same results so decided to get a new battery seeing it was 5 years old anyway. $376 later and the same problem. Brought it to a local mechanic and the obdc codes say it is the transfer case actuator. Seems awefully coincidental that this all started from a brake job. I think I may get it fixed and sell the car, this is baloney. If anyone can tell me what the fix was I would appreciate it.
    Reply With Quote Reply With Quote 174.4.19.197

  16. #16
    2008_X3_56K
    Guest
    Location
    , ,
    Member No: 2008_X3_56K's Avatar


    Yes | No

    4X4(yellow),BRAKE (yellow), seatbelt(red) lights On together on Dashboard

    It was snow yesterday and all 3 lights came off together and not going away. It happened earlier but went off quickly.

    I took to dealer for some noise and they said that they rerockers and lifters and since then I noticed which is the overhead passenger airbag yellow light ( not on Dashboard , its overhead) is lit for last 1 week. Now this this 3 lights came together. Another observation is that after the 3 lights went ON the DTC button is not working.

    I'm wondering if this Trio lights is due to snow covering the sensors or due to what they were doing with lifters and rockers last week.
    Reply With Quote Reply With Quote 146.115.121.126

  17. #17
    Unregistered
    Guest
    Location
    , ,
    Member No: Unregistered's Avatar


    Yes | No

    Dash lights as well

    I have an 08 X3 with 97k. I had the brakes done at 82k and recently had new tires put on (at a BMW dealer). While backing out of my driveway slowly and turning I felt my front brakes clamp down and bring me to a complete stop without me applying the brake. Later when I pulled into a parking spot at work it did the same thing. This continued over the weekend, then completely stopped. It was during this time my ABS, 4x4, Brake and Airbag lights came on the dash. I monitored this for a while as it seemed not to impede or make a difference in driving the vehicle. Sometimes the lights would never come on throughout the day, other times they came on right away. When we finally got a significant amount of snow I realized that when the lights came on I lost all power to the front wheels, abs braking and traction control. I brought the vehicle into the mechanic (not a BMW dealer) and was told that I had a bad actuator in the transfer case. Given the other posts it seems like a lot of this happens after some sort of brake work. This is my second X3 and have always been happy with the vehicle but now beginning to think Japanese.
    Reply With Quote Reply With Quote 67.136.167.134

  18. #18
    RippedOffByBMW
    Guest
    Location
    , ,
    Member No: RippedOffByBMW's Avatar


    Yes | No

    BMW X3 Transfer Case Actuator failure one week after Brake pad cahnge

    Quote Originally Posted by Unregistered View Post
    I have an 08 X3 with 97k. I had the brakes done at 82k and recently had new tires put on (at a BMW dealer). While backing out of my driveway slowly and turning I felt my front brakes clamp down and bring me to a complete stop without me applying the brake. Later when I pulled into a parking spot at work it did the same thing. This continued over the weekend, then completely stopped. It was during this time my ABS, 4x4, Brake and Airbag lights came on the dash. I monitored this for a while as it seemed not to impede or make a difference in driving the vehicle. Sometimes the lights would never come on throughout the day, other times they came on right away. When we finally got a significant amount of snow I realized that when the lights came on I lost all power to the front wheels, abs braking and traction control. I brought the vehicle into the mechanic (not a BMW dealer) and was told that I had a bad actuator in the transfer case. Given the other posts it seems like a lot of this happens after some sort of brake work. This is my second X3 and have always been happy with the vehicle but now beginning to think Japanese.
    I have a 2007 BMW X3 with only 39K ml. On 01/23/2012, I got brake pad change for my rear wheels. Just exactly 1 week later, on 01/30/2012, I have Brake + ABS + 4X4 indicators all on, thunder-loud sounds from the back of the car, can not turn, can not move. Towed to BMW dealer, first, they siad it is nothing to do with brake job eaqrlier on, and it need re-programe the software, later told me, it is my bad luck, random mecahnical part failure, I need to replace "Transfer Case Actuator" at $2820. After talked with dealer for a long time to show them what I found from internet, they still insist it is my own issue, nothing to do with BMW's quality.
    Reply With Quote Reply With Quote 24.30.21.249

  19. #19
    User Level 1
    Location
    , ,
    Member No: 190296 Gatorjgt is an unknown quantity at this point Gatorjgt's Avatar
    Join Date
    Feb 2012
    Posts
    1
    Rep Power
    0


    Yes | No
    I have a 2005 X3 with 104,000 miles on it and about 2 weeks ago the same lights came on and I felt some drag on my rear wheels when turning. Brought it in to an import auto repair shop and they said that I will need a new transfer case for a cost of $3,100 NAND further found a leak in oil gasket in oil filter housing which will cost $500 to repair. He said that I should expect to pay $2,500 in repairs a year due to the mileage. Probably time to get rid of it and get a new vehicle. I really like the X3 as it is not too large but enough so to carry clubs, road bike, etc. Any recommendations?
    Reply With Quote Reply With Quote 98.117.87.165

  20. #20
    User Level 1
    Location
    , ,
    Member No: 189968 bgkm is an unknown quantity at this point bgkm's Avatar
    Join Date
    Jan 2012
    Posts
    3
    Rep Power
    0


    Yes | No
    I got 3 opinions and quotes on my car with the ABS 4X4 and brake light problem. Each case it was the transfer case actuator, I got it fixed for $1100 and it runs like a dream again.
    Reply With Quote Reply With Quote 174.4.19.197

+ Reply to Thread
Page 1 of 2 1 2 LastLast


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum