+ Reply to Thread
Results 1 to 7 of 7
  1. #1
    Registered Member
    Location
    , ,
    Member No: 146775 jabrock is an unknown quantity at this point jabrock's Avatar
    Join Date
    Nov 2006
    Posts
    30
    Rep Power
    0


    Yes | No

    Engine running cold

    I have 95 M3 with s50 engine which recently will not get up to operating temperature. Today ambient temperature was 45 degrees and the gauge barely gets out of the blue area. I've also notice decrease in gas mileage. Could this be interconnected and would you assume that it most likely the thermostat that is bad? Also, have slight oil leak from front of engine dripping onto the line running to the A/C condenser in front of radiator. Anyone know that this is common problem and is there a fix? Thanks


  2. #2
    Registered Member
    Location
    , ,
    Member No: 146775 jabrock is an unknown quantity at this point jabrock's Avatar
    Join Date
    Nov 2006
    Posts
    30
    Rep Power
    0


    Yes | No

    Re: Engine running cold

    s50 engine running cold, will not heat up to operating temperature. Suspect thermostat or sensor as I'm getting poor gas mileage as well. Anyone know if this is related. Also have slight oil leak at front of engine with oil running down onto the A/C lines going to radiator on passenger side. Is this a common problem and is there an easy fix.

  3. #3
    Registered Member
    Location
    , ,
    Member No: 146775 jabrock is an unknown quantity at this point jabrock's Avatar
    Join Date
    Nov 2006
    Posts
    30
    Rep Power
    0


    Yes | No

    Re: Engine running cold

    what is wrong with this forum. It's not posting any new post and half the times it won't let you get the the page.

  4. #4
    Registered Member
    Location
    , ,
    Member No: 17062 JKRIT is on a distinguished road JKRIT's Avatar
    Join Date
    Oct 2001
    Posts
    2,203
    Rep Power
    17


    Yes | No

    Definitely thermostat

    and change the plastic thermostat housing (they can crack with age) and "pork chop" gasket while you're at it. If you don't know how to do this job, I suggest you search archives here or the general E36 board (which has much more traffic nowadays, BTW). It's an easy DIY, but the most important thing is to bleed all the air out of the cooling system when you have topped it up after installing your t-stat.

    Oil leaks are "common" on any car this old. Start by cleaning the area off and see if you can track it to the source on the clean surfaces. Valve cover gaskets leaks are common, but more often leak onto the exhaust, out the back or into the spark plug wells. Power steering hose leaks are also very common, but that's on the opposite side of where U described.

    Good luck.
    '01 325it Steel Blu./Blk
    '98 323is Arctic Sil./Blk, SP
    '97 528i Montreal Blu./Grey
    '95 M3 Cosmos Blk./Blk

  5. #5
    ADS
    Guest
    Location
    , ,
    Member No: ADS's Avatar


    Yes | No

    3 things

    1. Thermostat - as somebody said - the temp would be VERY slow to get up to temp if stuck open, but should go into red if stuck closed.
    2. Temp sensor/sending unit- maybe ties into your gas mileage if ECU/DME is getting a bad temp reading and not adjusting to real engine temp
    3. bad gauge

    Good luck

    Yeah, this forum is all but dead, but gets less fanboi crap than some others...

    ADS

  6. #6
    Registered Member
    Location
    , ,
    Member No: 146775 jabrock is an unknown quantity at this point jabrock's Avatar
    Join Date
    Nov 2006
    Posts
    30
    Rep Power
    0


    Yes | No

    Re: Definitely thermostat

    Thanks JKRIT. I've got a Bentley manual and will refer to it on changing out the thermostat. Considering changing out the water pump for the Stewart High Performance Water Pump rather than the OEM with metal impeller, if the pump is bad. Can't remember if the previous owner changed it already or not.

  7. #7
    Registered Member
    Location
    , ,
    Member No: 146775 jabrock is an unknown quantity at this point jabrock's Avatar
    Join Date
    Nov 2006
    Posts
    30
    Rep Power
    0


    Yes | No

    Re: 3 things

    Thanks ADS. I use to be on the e28 board until a deer ran out if front of my 535. A big deer ruining the hood, grill and driver's side fender. Why do they all come at you from the left. Anyway, quite familiar with the sensors, cold start valve and numerous other switches on them to think the e36 if it senses it's cold may be running a little rich. I'll change out the thermostat first then get change out the more expensive parts if problem persist.

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum