+ Reply to Thread
Results 1 to 6 of 6

Thread: Engine code

  1. #1
    Steve
    Guest
    Location
    , ,
    Member No: Steve's Avatar


    Yes | No

    Engine code

    I have an engine code from my Peake tool of 41. I believe that is, A/C Compressor. It is on a 1998 M3. Does anyone know what the cause of this is and can I fix it? Do I need a new compressor? Thanks for the help.


  2. #2
    Registered Member
    Location
    , , United States
    Member No: 49533 95DayVI is an unknown quantity at this point 95DayVI's Avatar
    Join Date
    Sep 2002
    Posts
    16,858
    Rep Power
    0


    Yes | No

    you can find codes listed online usually are 12xx

    _______
    Silicone intake boot
    Silicone rad hoses
    EMP Waterpump
    PWR Radiator
    Eyeball Arm CA mounts
    Sunbelt CAMS w chip for 24# injectors, Euro MAF, Conforti/ITG CAI
    96+ exhaust manifolds
    accessory UDPs
    M roadster lever
    Euro fLoAtErS
    GC RTAB shims, RSMs, T/S Coilover with Koni DA f/SA R & 450#f/550#r Eibach ERS
    All done in my garage

    corkscrew:Laguna Seca

  3. #3
    Registered Member
    Location
    goleta, CA, United States
    Member No: 46996 tjm3 is an unknown quantity at this point tjm3's Avatar
    Join Date
    Aug 2002
    Posts
    148
    Rep Power
    0


    Yes | No

    Re: Engine code

    According to the code list that came with my Peake tool, code 41 is the camshaft sensor.

  4. #4
    Registered Member
    Location
    goleta, CA, United States
    Member No: 46996 tjm3 is an unknown quantity at this point tjm3's Avatar
    Join Date
    Aug 2002
    Posts
    148
    Rep Power
    0


    Yes | No

    Re: Engine code

    I also don't find any recalls or TSBs for the cam sensor. It has three wires and is more than likely a Hall sensor type and can probably be checked for glitches with a good meter or a scope.

  5. #5
    Registered Member
    Location
    Lakewood, CO, United States
    Member No: 96664 stevejfy is an unknown quantity at this point stevejfy's Avatar
    Join Date
    Dec 2003
    Posts
    2
    Rep Power
    0


    Yes | No

    Re: Engine code


  6. #6
    Steve
    Guest
    Location
    , ,
    Member No: Steve's Avatar


    Yes | No

    Re: Engine code

    I did change out the Cam Sensor and that cleared the CEL. Thanks

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum