+ Reply to Thread
Results 1 to 3 of 3
  1. #1
    Fluke/CapeCod
    Guest
    Location
    , ,
    Member No: Fluke/CapeCod's Avatar


    Yes | No

    Good to Bad gas mileage ...any ideas of cause

    3 MAF sensors ago and some 3 years ago I was getting 25 MPG around town and 30 MPG highway.. This stayed consistant up until I wrecked my MAF sensor and bought a new (used/ $150.00) one. Then it dropped to 22 MPG around town and 25 highway...
    Then I wrecked that one by using the wrong cleaner. Now with this, 3rd, new (used/$100)(good news is they are coming down in price) MAF sensor I am getting 19 MPG around town and 19 MPG highway...(83MPH) yet the place where I bought these used MAF sensors said there is no differences in these MAF sensors, One sensor fits all 2.8L be it my Coupe or any 3-Series and (5-series ?) they are all the same...

    based on what I see with this mileage I'd say someone is wrong here.. because that's the only thing I have messed with, so that leads me to believe thats the culprit.

    any opinions or insights on the specs of these MAF sensors????


  2. #2
    peppercorn
    Guest
    Location
    , ,
    Member No: peppercorn's Avatar


    Yes | No

    I may need a new MAF as well.

    Having issues with cold starts still. I THINK it's the MAF since I've been using an over oiled K&N for some time now and maybe it's done harm. Tried cleaning the MAF and replacing the K&N with a premium paper filter. No change... so ...

    Mechanic suggested it could also be the crank sensor.

    He also claims little good comes from cleaning the MAF.

    Where are you getting these used MAF? Seems like you might need to bite the bullet and get a NEW one.

    My mileage really hasn't changed for some time now regardless of all this. I used to get 26+ mpg when the car was much newer... maybe my K&N over oiling damaged the MAF long ago and my current issue is related to the crank sensor...

    oh the drama.

  3. #3
    peppercorn
    Guest
    Location
    , ,
    Member No: peppercorn's Avatar


    Yes | No

    Talked my mechanic about MAFs

    He was pretty sure they are calibrated specifically for each car. I'd check the part numbers on all the MAF's you've tried, see if any match up.

    Have you noticed a difference in how the car starts up? Any difference in power, or the delivery of power?

    Might be worth biting the bullet and ordering a warrantied part directly from BMW. I'm having issues with mine as well and I plan to buy new from BMW.

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum