+ Reply to Thread
Results 1 to 10 of 10

Hybrid View

  1. #1
    Fluke/CapeCod
    Guest
    Location
    , ,
    Member No: Fluke/CapeCod's Avatar


    Yes | No

    ABS light comes on when its raining (only)

    this ABS light coming on problem has occurred only in the last three weeks and it has been raing out when it comes on...

    My hunch is that rain water is shorting some relay out at one of the wheels...

    the car is fine and the lights off other than this situation with the rain.

    any insights on what may be the root of this evil ? Or is it to the contrary, and that evil is not playing a role in this matter ?

  2. #2
    peppercorn
    Guest
    Location
    , ,
    Member No: peppercorn's Avatar


    Yes | No

    My ABS was on/off for some time before it failed..

    completely. Had it tested twice using bmw hardware and they claimed the main control module had died. Moisture/weather and driving conditions all seemed to play a role before it failed completely. But I think it was more random then anything else.

    But you could have a short somewhere considering you're exp. your problem in high humidity/rain. Have you checked all four corners?

    Hit anything on the road lately? cones at the autoX?

  3. #3
    PbFut
    Guest
    Location
    , ,
    Member No: PbFut's Avatar


    Yes | No

    I have parts off a 99 if you need

    Not sure what year you have. I have pump and control unit off Project99 if you need them.

  4. #4
    peppercorn
    Guest
    Location
    , ,
    Member No: peppercorn's Avatar


    Yes | No

    hmmm, how many miles on the parts?

    I have a 1999 (10/98 build) 2.8L with the ASC system.

    I would probably need both those parts. what would you like for them, and can you guess the total weight?

    .

  5. #5
    Registered Member
    Location
    Valencia (Spain), , spain
    Member No: 79547 bmz321 is an unknown quantity at this point bmz321's Avatar
    Join Date
    Jun 2003
    Posts
    30
    Rep Power
    0


    Yes | No

    ABS relay?

    Hello guys.

    Perhaps is more simple.... and cheaper.
    I remember some abs fails and the problem was in abs relay, below steering plastic cover.

    Good luck.

  6. #6
    peppercorn
    Guest
    Location
    , ,
    Member No: peppercorn's Avatar


    Yes | No

    would this relay failure not spit out a code?

    the dealer ran the codes, they claim the main control unit. perhaps a relay could block signal to the main unit and then inturn spit out a code saying the main control unit is dead?

  7. #7
    PbFut
    Guest
    Location
    , ,
    Member No: PbFut's Avatar


    Yes | No

    Re: hmmm, how many miles on the parts?

    Less than 40K total miles. email me.

  8. #8
    peppercorn
    Guest
    Location
    , ,
    Member No: peppercorn's Avatar


    Yes | No

    I found your frankn coupe page.

    You commented on the ASC system and suggested the Delete kit. Is that more for track coupes? I don't really MISS the ASC system at all, never used it really. ABS is always nice to have though.

    so these parts have about 36k on them?


  9. #9
    Cochise
    Guest
    Location
    , ,
    Member No: Cochise's Avatar


    Yes | No

    ABS control module?

    We just went through this with the M Coupe race car we restored. I'm going to post pics some time this week actually of the build.

    Back to the matter at hand. The ABS light was on at the bottom of the instrument cluster. In addition, I couldn't talk to the ABS unit with the diagnostic tool. I called a bunch of people and many of them swore that the ABS control modules under the passenger dash area box DO NOT FAIL. However, it did. I purchased a used one from one of the local LKQ BMW auto parts yards and boom, good to go. The unit new from the dealer was almost $800. This unit was out of a crashed used Z3 and it was fine. $195 and a ride to Jacksonville and no more issues. I'm lucky though because I guess that Orlando/Jacksonville is a huge BMW salvage area.

    Again, if it comes and goes like that, it might be a wheel speed sensor but I'm thinking you're having the same issues we did. Is there any water getting in anywhere underneath the passenger dash area? See if you have a friend that will lend you their unit if their parking/storing their car. Or track one down. I have part numbers and the such if you need them.

    Good luck.

    John

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum