+ Reply to Thread
Results 1 to 3 of 3
  1. #1
    Registered Member
    Location
    , ,
    Member No: 47222 Chris_Edmond is an unknown quantity at this point Chris_Edmond's Avatar
    Join Date
    Aug 2002
    Posts
    124
    Rep Power
    0


    Yes | No

    BMW E39 DSP changer no sound

    I have a 99 540 auto (built 04/99)with the dsp high end sound system.

    It has satnav and a tel.

    The problem I have is with the 6 disc changer. The changer is loading the discs (all 6) I believe it is playing the discs. I know this because if left the cd seems to play the first track and after say 3min 30secs it moves onto the second track. The display on the dash says it has moved to track 2.

    The problem is there is no sound. The coaxial cable from the cd player to the DSP Amp is there and plugged in. I have checked it at both ends and its connected. The cable goes behind the mounting frame for the Satnav frame but where I can see this cable it seems to be intact and in good condition.

    I've searched the forums and can't seem to see anyone with the same problem.

    Do i just need a new coaxial cable?

    Not sure I know anyone with a similar car who I could swap the bits over to check the components

    HELP

    Chris



  2. #2
    Registered Member
    Location
    , ,
    Member No: 21537 sktn77a is an unknown quantity at this point sktn77a's Avatar
    Join Date
    Dec 2001
    Posts
    1,229
    Rep Power
    0


    Yes | No

    Re: BMW E39 DSP changer no sound

    Send an e-mail to Daryl Willman at Willman's Electronics in Texas. They can check out the CD changer for you to see if its a changer problem or a cable problem.

    Keith
    2001 530i 5sp

  3. #3
    Registered Member
    Location
    , ,
    Member No: 178944 asingh9690 is an unknown quantity at this point asingh9690's Avatar
    Join Date
    Jan 2010
    Posts
    1
    Rep Power
    0


    Yes | No

    Re: BMW E39 DSP changer no sound

    I got the same problem
    cd player is playing but no sound
    wire is good i think its the input on the dsp amp

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum