+ Reply to Thread
Results 1 to 6 of 6

Hybrid View

  1. #1
    Registered Member
    Location
    Malvern, PA, United States
    Member No: 148310 Pmb2685 is an unknown quantity at this point Pmb2685's Avatar
    Join Date
    Dec 2006
    Posts
    9
    Rep Power
    0


    Yes | No

    Repeated Oxygen Sensor Issue

    Anyone That Can Help,

    I have a 95 M3 that is my pride and joy!! My car just turned 160,000 miles. About a year ago I started to have a problem with the Oxygen Sensor. I threw a check engine light and ran my code reader to find that it was an Oxygen Sensor issue. I took the car to my mechanic who replaced the Sensor and all was well (or so I thought). I have replaced the Sensor 3 times in the past year after repeated check engine lights and new sensors. I trust my mechanic who specifically works on BMW's completely but he cannot figure out what the issue is. He has run wires bypassing all relays to make sure that itís not a relay or wiring issue. He has installed and run the car with a different OBC, which failed to fix the issue! I figured I would turn to you guys for any advice or to see if anyone has experienced the same issues. I would appreciate any input that might be of assistance! Thanks Guys!

  2. #2
    HSV-Dan
    Guest
    Location
    , ,
    Member No: HSV-Dan's Avatar


    Yes | No

    Re: Repeated Oxygen Sensor Issue

    Are you handy with a volt meter? Check the active lead with an analog meter to see if it is working. A working sensor and working control unit will have a very slow oscillation from zero to about 1 VDC. The voltage slould swing back and forth about every second or so. This will confuse most digital meters... If it is stuck at one extreme, you are running either rich or lean (I just don't recall if 0 volts is rich, or if it is lean). Other things can cause the system to be out of whack and the ECU won't be able to compensate.

    Does the heater circuit work? One of the wires on the O2 is 12V for a built in heater, should turn on at start up to bring the sensor up to temp while the exhaust catches up.

    If the voltages look right, maybe its the ECU making a bad decison?

    Search the web for chemicals that may contaminate the sensor, are you using any unusual injector cleaners?

  3. #3
    Registered Member
    Location
    Malvern, PA, United States
    Member No: 148310 Pmb2685 is an unknown quantity at this point Pmb2685's Avatar
    Join Date
    Dec 2006
    Posts
    9
    Rep Power
    0


    Yes | No

    Re: Repeated Oxygen Sensor Issue

    Thanks for the reply, I will give those ideas a go and see what I find out. I'll post with results.

  4. #4
    Registered Member
    Location
    London, , Canada
    Member No: 35097 bbojangles is an unknown quantity at this point bbojangles's Avatar
    Join Date
    May 2002
    Posts
    838
    Rep Power
    0


    Yes | No

    need the exact codes.. there are many for o2

    sensor..

    actually i will declare it is IMPOSSIBLE to trouble shoot with logic (the only kind that can work reliably in cyberspace).
    The codes are very specific and trouble shooting is also technical and specific.. mechanics are all too quick to add an O2 sensor..

    read here if you want some details..
    I just threw a P0133 ..

    http://www.bba-reman.com/content.aspx?content=NEXT_DTC_P0133_NEW_2

  5. #5
    Registered Member
    Location
    goleta, CA, United States
    Member No: 46996 tjm3 is an unknown quantity at this point tjm3's Avatar
    Join Date
    Aug 2002
    Posts
    148
    Rep Power
    0


    Yes | No

    Re: Repeated Oxygen Sensor Issue

    Seem obvious that the O2 sensor is not the problem if you replaced it three times this year.

    What's the code?

  6. #6
    Registered Member
    Location
    Malvern, PA, United States
    Member No: 148310 Pmb2685 is an unknown quantity at this point Pmb2685's Avatar
    Join Date
    Dec 2006
    Posts
    9
    Rep Power
    0


    Yes | No

    Re: Repeated Oxygen Sensor Issue

    Sorry guys I was on vacation... I don't have the ligit codes to give you, all I have is a Peak code reader that just throws a two digit code "0d" which in the book shows an O2 sensor.. Nothing figured out yet. Any help, ideas or opinions would still be appreciated.

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum