+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Registered Member
    Location
    Columbus, OH, United States
    Member No: 152819 zackkcaz is an unknown quantity at this point zackkcaz's Avatar
    Join Date
    May 2007
    Posts
    181
    Rep Power
    0


    Yes | No

    oops..not good

    So my water pump went today..found a new one at auto zone for $51...took the front of the engine apart replaced the pump put everything together....and something in the distributer/rotor is nicking something...when I start the car I can feel the dist. vibrating and hear it as well.I took the dist. apart and noticed one of the outside grounds was being hit by rotor...put it back together very carefully and its still doing it..I drove it about 7 miles and all was fine...It actually drove a lot better for some reason..no bucking or lurching when I shift from 1st to 2nd and idles lower. Any ideas on what I should check?
    1997 528i auto. Silver with gray interior.

    1986 528e manual.


  2. #2
    Registered Member
    Location
    Conroe, TX, United States
    Member No: 136776 Mark_88_M5 is on a distinguished road Mark_88_M5's Avatar
    Join Date
    Jan 2006
    Posts
    529
    Rep Power
    11


    Yes | No

    Sounds like time for a new rotor and cap.


+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum