+ Reply to Thread
Results 1 to 7 of 7
  1. #1
    Registered Member
    Location
    , ,
    Member No: 124915 jcstr1966 is an unknown quantity at this point jcstr1966's Avatar
    Join Date
    Apr 2005
    Posts
    14
    Rep Power
    0


    Yes | No

    a diiferent steering concern

    My 2003 Z4 3.0 has begun to develop a "groan" noise when I turn the steering wheel. Sounds like something needs lubrication. Used to happen when i first started to drive but now seems to occur oft and on when I'm driving. Anybody experience a similar problem and if so, were you able to get it fixed?
    Thanks.


  2. #2
    Registered Member
    Location
    Lynnwood, WA, United States
    Member No: 20384 edhchoe is an unknown quantity at this point edhchoe's Avatar
    Join Date
    Dec 2001
    Posts
    3,707
    Rep Power
    0


    Yes | No

    have you checked the fluid level?

    .

  3. #3
    Registered Member
    Location
    Lynnwood, WA, United States
    Member No: 20384 edhchoe is an unknown quantity at this point edhchoe's Avatar
    Join Date
    Dec 2001
    Posts
    3,707
    Rep Power
    0


    Yes | No

    It takes tranny fluid...(nt)


  4. #4
    Registered Member
    Location
    , ,
    Member No: 124915 jcstr1966 is an unknown quantity at this point jcstr1966's Avatar
    Join Date
    Apr 2005
    Posts
    14
    Rep Power
    0


    Yes | No

    Re: have you checked the fluid level?

    Haven't checked the level. Can you describe where the power steering reservoir is located?
    thanks.

  5. #5
    Registered Member
    Location
    , ,
    Member No: 124915 jcstr1966 is an unknown quantity at this point jcstr1966's Avatar
    Join Date
    Apr 2005
    Posts
    14
    Rep Power
    0


    Yes | No

    Re: have you checked the fluid level?

    I don't think the Z4 has a hydraulic system. I believe it uses an electric assist. Anyone else weigh in on this?
    Tks

  6. #6
    Bad Email Address on File
    Location
    , ,
    Member No: 84505 Penguin is an unknown quantity at this point Penguin's Avatar
    Join Date
    Aug 2003
    Posts
    1,723
    Rep Power
    0


    Yes | No

    Re: have you checked the fluid level?

    Good luck finding the reservoir... the Z4 does not have any power steering fluid since it is an totally electric, not hydraulic, system.

  7. #7
    Registered Member
    Location
    , , United States
    Member No: 81792 lool is an unknown quantity at this point lool's Avatar
    Join Date
    Jul 2003
    Posts
    971
    Rep Power
    0


    Yes | No

    Re: a diiferent steering concern

    You guys are kidding right? Where have you been?

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum