+ Reply to Thread
Results 1 to 12 of 12

Hybrid View

  1. #1
    Registered Member
    Location
    Irvine, CA, United States
    Member No: 33493 schiano is an unknown quantity at this point schiano's Avatar
    Join Date
    Apr 2002
    Posts
    531
    Rep Power
    0


    Yes | No

    SMG warning light just came on - help!

    I just got an SMG warning light. The car seems to go into a limp mode where the setting is set to S1 or S2. Is that supposed to happen?

    The warning light just came on unexpectedly. Maybe just needs to be reset - I hope. I'll take it my garage soon to find out what's up.

    Any idea of what could have happened? Car was running fine until the light came on.

    Haven't posted in a while - hope someone is out there :)

    Allen

  2. #2
    Registered Member
    Location
    Exeter, NH, United States
    Member No: 57671 E36M3owner is an unknown quantity at this point E36M3owner's Avatar
    Join Date
    Nov 2002
    Posts
    155
    Rep Power
    0


    Yes | No

    Re: SMG warning light just came on - help!

    I have had the SMG light ('03 M3) come on on two different occasions. Both times the light reset itself when the car was restarted and I did not observe any change in shifting or vehicle performance, so your current experience is different than mine. I did not have a code reader at the time.

    In my case, at least one of the two incidents appeared when I got in the car and immediately started it. At the time I thought that I may have started it so quickly after opening the door that the SMG pressure pump had not had time to get full pressure in the SMG system prior to that startup.

    Good luck on the outcome.

    This board is not very active any more, but I still enjoy visiting it.

  3. #3
    Registered Member
    Location
    Girloy, CA, United States
    Member No: 14325 Ispep is an unknown quantity at this point Ispep's Avatar
    Join Date
    Oct 2001
    Posts
    4,609
    Rep Power
    0


    Yes | No

    Coworker had same thing happen

    Turned out to be a bad SMG pump.

  4. #4
    Allen Schiano
    Guest
    Location
    , ,
    Member No: Allen Schiano's Avatar


    Yes | No

    bad SMG pump or worn clutch?

    Any idea how much that cost him?

    This morning it reset itself and the car worked fine.

    Then about 20 minutes into my morning drive I tried to shift into 3rd and the clucth seemed to slip, i.e., not engage in the S% mode speed shift. Then the light came on again and it started limping in S1 or S2.

    Argh.

    A couple times now it seems to be slipping as it engages.

    So the question is: bad clutch or bad pump? The car has 138K miles so could be either. Looks like I have an expense coming up...

  5. #5
    Registered Member
    Location
    Girloy, CA, United States
    Member No: 14325 Ispep is an unknown quantity at this point Ispep's Avatar
    Join Date
    Oct 2001
    Posts
    4,609
    Rep Power
    0


    Yes | No

    His was pump, but he replaced it himself

    So I'm not sure what he paid for the part alone. The problem with the SMG error light is that it's too vague so you don't know what exactly is wrong without talking to the dealer or taking a shot in the dark if you're going the DIY route. The slippage might be fixed by doing an SMG reset.

  6. #6
    Allen Schiano
    Guest
    Location
    , ,
    Member No: Allen Schiano's Avatar


    Yes | No

    Indy shop wants about $2500 for replacement

    Says part iabout $2000 from BMW. Ack! And 6 hours of labor.

    We'll see what the problem is. They didn't think it was realy since that failuire just doesn't start the pump. And my pump starts but has problems.

    Not likely to be clutch either since while in gear clutch seems to engage nicely.

    Ack! $2500 repair at Christmas. Oh well, there are plenty of worse problems in the world.

    Allen

  7. #7
    Registered Member
    Location
    Girloy, CA, United States
    Member No: 14325 Ispep is an unknown quantity at this point Ispep's Avatar
    Join Date
    Oct 2001
    Posts
    4,609
    Rep Power
    0


    Yes | No

    Could be SMG relay. I think that's only few $100


+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum