+ Reply to Thread
Results 1 to 15 of 15

Hybrid View

  1. #1
    Registered Member
    Location
    , ,
    Member No: 142349 dsklav is an unknown quantity at this point dsklav's Avatar
    Join Date
    Jun 2006
    Posts
    9
    Rep Power
    0


    Yes | No

    1997 740il Wipers don't work? Radio doesn't work?

    Problem #1 I need help I bought a 1997 740il at auction. At first the wipers were stuck in the middle of the windshield? Didn't go down. After letting car runs for 30 minutes hit the switch and they went down only worked for a few seconds on High and then stopped all together again? Haven't worked since. Any suggestions as to what could cause this? I have tried replacing the handle switch on the steering column with no success. All fuses seem to be fine. The only thing I don't know about is if there is a relay to check? Any help would be great.

    Problem #2 same car as above bought the car and the radio was not working. After letting the car run for awhile the radio started to work then I turned the car off and the radio no longer works. Any ideas?

  2. #2
    Registered Member
    Location
    , ,
    Member No: 142349 dsklav is an unknown quantity at this point dsklav's Avatar
    Join Date
    Jun 2006
    Posts
    9
    Rep Power
    0


    Yes | No

    Re: 1997 740il Wipers don't work? Radio doesn't work?

    Sorry forgot to mention radio acts like it has no signal? If you hit scan it goes through all the stations without stopping? Would that mean antenna is broken?

  3. #3
    Registered Member
    Location
    , ,
    Member No: 58142 ROYinGA is an unknown quantity at this point ROYinGA's Avatar
    Join Date
    Nov 2002
    Posts
    2,633
    Rep Power
    0


    Yes | No

    How old is your battery? Have you ever had to

    change your ignition switch. A bad switch or an old weak battery will cause strange things to happen.

  4. #4
    Registered Member
    Location
    , ,
    Member No: 142349 dsklav is an unknown quantity at this point dsklav's Avatar
    Join Date
    Jun 2006
    Posts
    9
    Rep Power
    0


    Yes | No

    Re: How old is your battery? Have you ever had to

    Brand New Battery. It was bad and I replaced it. Would that cause the radio no to work? Thanks for the help.

  5. #5
    Registered Member
    Location
    , ,
    Member No: 58142 ROYinGA is an unknown quantity at this point ROYinGA's Avatar
    Join Date
    Nov 2002
    Posts
    2,633
    Rep Power
    0


    Yes | No

    Old batteries and old ignition switches sometines

    cause strange Gremlins.

  6. #6
    MRHNIC
    Guest
    Location
    , ,
    Member No: MRHNIC's Avatar


    Yes | No

    Re: Old batteries and old ignition switches sometines

    Had the same problem on my 1998 740iL. I tried all of the above mentioned fixes but ultimately had to take it to the dealer who replace something that was broken in the steering wheel hub.

  7. #7
    Registered Member
    Location
    , ,
    Member No: 58142 ROYinGA is an unknown quantity at this point ROYinGA's Avatar
    Join Date
    Nov 2002
    Posts
    2,633
    Rep Power
    0


    Yes | No

    Wiper relays are under the DME in the electric box

    in the engine compartment.

  8. #8
    Registered Member
    Location
    , ,
    Member No: 142349 dsklav is an unknown quantity at this point dsklav's Avatar
    Join Date
    Jun 2006
    Posts
    9
    Rep Power
    0


    Yes | No

    Re: Wiper relays are under the DME in the electric box

    I pulled out the DME which relay or relays is it? I have 3 under there to choose from? One is like pink and says abs the other two are both purple. Thanks, William

  9. #9
    Registered Member
    Location
    , ,
    Member No: 58142 ROYinGA is an unknown quantity at this point ROYinGA's Avatar
    Join Date
    Nov 2002
    Posts
    2,633
    Rep Power
    0


    Yes | No

    I'm not sure whether they are under the DME or EGS

    modules. The WDS says it is 2 dark colored ones side by side toward the driver.

  10. #10
    Registered Member
    Location
    , ,
    Member No: 142349 dsklav is an unknown quantity at this point dsklav's Avatar
    Join Date
    Jun 2006
    Posts
    9
    Rep Power
    0


    Yes | No

    Re: I'm not sure whether they are under the DME or EGS

    I replaced both relays and still the wipers don't work????? Any other Suggestions on what it could be?

  11. #11
    Registered Member
    Location
    , ,
    Member No: 142349 dsklav is an unknown quantity at this point dsklav's Avatar
    Join Date
    Jun 2006
    Posts
    9
    Rep Power
    0


    Yes | No

    Re: 1997 740il Wipers don't work? Radio doesn't work?

    Thanks I will try that and see what happens. Any ideas on the radio not working?

  12. #12
    Registered Member
    Location
    , ,
    Member No: 163750 montainhi is an unknown quantity at this point montainhi's Avatar
    Join Date
    Apr 2008
    Posts
    5
    Rep Power
    0


    Yes | No

    Re: 1997 740il Wipers don't work? Radio doesn't work?

    experienced similar symptoms - like intermittent video monitor MKIII display, at times radio audio is on but no video display, or no audio or video display at all. like other posts recommended, i replaced the electric switch on the ignition. completed the task and everything seems to be working, video monitor and radio on, but more than than 15 minutes later, the the interior lights dimmed, and completely lost video and radio signals. tried a couple of times turning on/off the main ignition switch but could not regain video and radio signal. it could be my battery - more than 5 years old, causing all the troubles, besides the car has been has not been started for three weeks while trying to complete my cooling system work.

  13. #13
    Registered Member
    Location
    , ,
    Member No: 142349 dsklav is an unknown quantity at this point dsklav's Avatar
    Join Date
    Jun 2006
    Posts
    9
    Rep Power
    0


    Yes | No

    Re: 1997 740il Wipers don't work? Need Help!!!!!!!

    I have replaced the relays that were under the computer! No luck wipers still don't work? Any suggestions on what else it could be? I really need help in getting this resolved.


  14. #14
    Registered Member
    Location
    , ,
    Member No: 142349 dsklav is an unknown quantity at this point dsklav's Avatar
    Join Date
    Jun 2006
    Posts
    9
    Rep Power
    0


    Yes | No

    Re: 1997 740il Wipers fixed! Replaced


  15. #15
    Registered Member
    Location
    , ,
    Member No: 142349 dsklav is an unknown quantity at this point dsklav's Avatar
    Join Date
    Jun 2006
    Posts
    9
    Rep Power
    0


    Yes | No

    Re: 1997 740il Wipers! Replaced Motor! Work Great!


+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum