+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Registered Member
    Location
    , ,
    Member No: 64746 pandith is an unknown quantity at this point pandith's Avatar
    Join Date
    Jan 2003
    Posts
    15
    Rep Power
    0


    Yes | No

    e34 m20 starter or electrical issue

    Hi,
    My 90 e34 525 is having a weird starter issue. The starter will crank but it will switch off in the middle at times as if somebody turned off the power. I have to try a couple of times and the car starts. This happens intermitantly. I searched the forum and the posts pointed to:
    1. Main relay issue.
    2. Starter switch.
    3. Starer motor.

    Before I buy any parts and start going through the process of elimination I thought I would check and see if anybody have any ideas of what else could be wrong.

    Thanks for the info


  2. #2
    Unregistered
    Guest
    Location
    , ,
    Member No: Unregistered's Avatar


    Yes | No
    Quote Originally Posted by pandith View Post
    Hi,
    My 90 e34 525 is having a weird starter issue. The starter will crank but it will switch off in the middle at times as if somebody turned off the power. I have to try a couple of times and the car starts. This happens intermitantly. I searched the forum and the posts pointed to:
    1. Main relay issue.
    2. Starter switch.
    3. Starer motor.

    Before I buy any parts and start going through the process of elimination I thought I would check and see if anybody have any ideas of what else could be wrong.

    Thanks for the info

    Make sure the terminals are tightly secured to the battery cables dude.
    Reply With Quote Reply With Quote 166.147.88.27

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum