+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 20 of 28

Hybrid View

  1. #1
    NC02Z3
    Guest
    Location
    , ,
    Member No: NC02Z3's Avatar


    Yes | No

    Who has original water pump??

    A curiousity question as my '02 gets older and older. With so many posts about bad water pumps and replacing them as a good maintenance idea, who has their original water pump still and how many miles on your Z3?? I still have mine but just 30,000 miles.

  2. #2
    Registered Member
    Location
    Madison, WI, United States
    Member No: 6581 jtp is an unknown quantity at this point jtp's Avatar
    Join Date
    Feb 2001
    Posts
    5,952
    Rep Power
    0


    Yes | No

    I still have mine

    2000 2.3, almost 140,000 miles. Am I playing Russian Roulette? Maybe. But by some peoples' standards, I could also be on my third water pump by now! I will install the Stewart (along with an entire cooling system overhaul) eventually. Just haven't gotten around to it yet. So I keep an eye and nose on the engine when I drive and I'm ready to pull over IMMEDIATELY at the first sign of any temp issues.

    JTP
    '00 Bright Red II, Black, Black 2.3

    PERFORMANCE: Dinan Stage II suspension, Dinan strut tower brace, Porterfield R4S brake pads, Goodyear Eagle F1 GS-D3 tires, UNGO MS8300 alarm, Doug Whalen Seat Bushings, Sylvania Silverstar headlights and fog lights. MAINTENANCE: Peake Research R5/fcx-II and SRS Reset Tools, Mity-Vac oil evacuator w/ brake bleeder, BMW Battery Tender. COSMETICS: Dinan Badge, OEM chrome exhaust tips, Magnetic stone guards, Roundel valve stem caps, Trunk-mounted Dragon sticker, WI plates: RES IPSA. COMFORT: Premium Package, Heated sport seats, “Z3 Roadster” heated vest (for wife), In-dash CD, LeatherZ MarkII armrest, OEM mesh windscreen. CAR CARE: Porter Cable random orbit buffer, Meguiars car care products, NOAH car cover, Plexus, Raggtop. EXTRAS: Z3Solutions warning triangle.

    My Home Page

  3. #3
    Registered Member
    Location
    highland, MD, United States
    Member No: 163554 mystreba is an unknown quantity at this point mystreba's Avatar
    Join Date
    Apr 2008
    Posts
    26
    Rep Power
    0


    Yes | No

    Heat issues related?

    My '98 1.9 has 160k with the original. But recently it's been running hot. At the same time, my heater has stopped working - blow cold no matter what. Is this a sign of a failing water pump? Or is the problem more likely just the thermostat?

  4. #4
    Registered Member
    Location
    New Paltz,, NY, United States
    Member No: 129783 kostverloren is an unknown quantity at this point kostverloren's Avatar
    Join Date
    Aug 2005
    Posts
    546
    Rep Power
    0


    Yes | No

    Re: Heat issues related?

    Most likely thermostat or air in your system. 1.9's didn't seem to have the same problem with W/P's as the 6 bangers.Kostverloren

  5. #5
    Registered Member
    Location
    , ,
    Member No: 129658 gerardw is an unknown quantity at this point gerardw's Avatar
    Join Date
    Aug 2005
    Posts
    100
    Rep Power
    0


    Yes | No

    Re: I still have mine

    Oh, I just stopped right where I was on I-84 in Hartford yesterday when the darn system blew. Guy in a pickup pulled me over to the side. That little tow hook that screws into the front bumper actually works pretty well.

    Mechanic took a look this morning couldn't tell whether it was radiator or what; has to get BMW coolant on Monday.

  6. #6
    Registered Member
    Location
    New Paltz,, NY, United States
    Member No: 129783 kostverloren is an unknown quantity at this point kostverloren's Avatar
    Join Date
    Aug 2005
    Posts
    546
    Rep Power
    0


    Yes | No

    Re: Who has original water pump??

    I replaced the w/p on my 02 with a Stewart at 35K miles. It was in perfect condition and the good news was that it had the composit impellar. All the early failures were on the plastic and metal impellars so you may be all right but I still wouldn't want to bet my engine on it. Anyone out there have the composit impellared pump fail on them? Kostverloren

  7. #7
    NC02Z3
    Guest
    Location
    , ,
    Member No: NC02Z3's Avatar


    Yes | No

    Re: Who has original water pump??

    Well you just tought me something today and I appreciate it. I did not know the '02 model had a different material. Thank you!

  8. #8
    Registered Member
    Location
    Gold Hill, OR, United States
    Member No: 21597 z3bigdaddy is an unknown quantity at this point z3bigdaddy's Avatar
    Join Date
    Dec 2001
    Posts
    11,788
    Rep Power
    0


    Yes | No

    307,000 miles on my original pump..

    Why, should I be worried?

    We the People of the United States, in Order to form a more perfect Union, establish Justice, insure domestic Tranquility, provide for the common defence, promote the general Welfare, and secure the Blessings of Liberty to ourselves and our Posterity, do ordain and establish this Constitution for the United States of America.
    A well regulated Militia, being necessary to the security of a free State, the right of the people to keep and bear Arms, shall not be infringed.
    Signature to be included in the footer of all your posts. (HTML is ok)
    Note: to include a picture in your signature, use HTML that looks like

    You may place a link to your own site in your signature if you have a
    reciprocal link to us on that page and follow the guidelines in our Link FAQ.
    Links in violation of the Link FAQ may be removed without warning. Please also
    do not include any pornographic or non-work-safe images in your signature.








  9. #9
    Registered Member
    Location
    , ,
    Member No: 43862 Shelc is an unknown quantity at this point Shelc's Avatar
    Join Date
    Jul 2002
    Posts
    48
    Rep Power
    0


    Yes | No

    Re: Who has original water pump??

    When did BMW switch to a composite impeller?

  10. #10
    NC02Z3
    Guest
    Location
    , ,
    Member No: NC02Z3's Avatar


    Yes | No

    Re: Who has original water pump??

    I'd like to know too if anyone has the answer.

  11. #11
    Registered Member
    Location
    New Paltz,, NY, United States
    Member No: 129783 kostverloren is an unknown quantity at this point kostverloren's Avatar
    Join Date
    Aug 2005
    Posts
    546
    Rep Power
    0


    Yes | No

    Re: Who has original water pump??

    Query RealOEM for a 2002 Z3 waterpump or ask your parts guy at BMW and you'll have the correct P/N for the composit impellar. The only way to really tell what you may have in your Z is to pull it out and look. I would venture to say that 2001 and 2002 have upgraded W/P's. I have found that probably most early problems were reported and corrected with engineering changes by the time the last Z3s rolled off the line.Case in point, no rocking seats, no sagging glove box, no broken welds in trunk floor or tears in rear diff. ear with my Z and it cleared manufacturing one month before production ceased. My first Corvette was a 64 coupe and was a piece of crap compared to the 67 I later bought, that was an early lesson I learned and always guided later buying decisions. Kostverloren

  12. #12
    Registered Member
    Location
    Spring Green, WI, United States
    Member No: 146192 s-retire is an unknown quantity at this point s-retire's Avatar
    Join Date
    Oct 2006
    Posts
    706
    Rep Power
    0


    Yes | No

    The water pump from my 2001...

    (production 12/2000) has a two piece stamped stainless impeller that is epoxied together.

    Not the best looking unit from the standpoint of pump efficiency.

  13. #13
    NC02Z3
    Guest
    Location
    , ,
    Member No: NC02Z3's Avatar


    Yes | No

    Re: Who has original water pump??

    Thank you very much for the information.

  14. #14
    Registered Member
    Location
    san martin, CA, United States
    Member No: 56117 bsrsystems is an unknown quantity at this point bsrsystems's Avatar
    Join Date
    Nov 2002
    Posts
    2,625
    Rep Power
    0


    Yes | No

    A good idea?????

    I have my original still installed, 97 2.8, 170k miles. But I bought a replacement pump, hoses, thermostat at 60k miles and carry them with me in the car Take up little space in the tool/battery compartment, and it's a job that is a DIYer if your in the middle of nowhere as well as having the main parts if she lets go in a civilized part of the country. Just a thought.

  15. #15
    Registered Member
    Location
    Gold Hill, OR, United States
    Member No: 21597 z3bigdaddy is an unknown quantity at this point z3bigdaddy's Avatar
    Join Date
    Dec 2001
    Posts
    11,788
    Rep Power
    0


    Yes | No

    Have to admit I bought a repacement too...

    My wife can sell it on ebaY after I'm dead and buried...

    We the People of the United States, in Order to form a more perfect Union, establish Justice, insure domestic Tranquility, provide for the common defence, promote the general Welfare, and secure the Blessings of Liberty to ourselves and our Posterity, do ordain and establish this Constitution for the United States of America.
    A well regulated Militia, being necessary to the security of a free State, the right of the people to keep and bear Arms, shall not be infringed.
    Signature to be included in the footer of all your posts. (HTML is ok)
    Note: to include a picture in your signature, use HTML that looks like

    You may place a link to your own site in your signature if you have a
    reciprocal link to us on that page and follow the guidelines in our Link FAQ.
    Links in violation of the Link FAQ may be removed without warning. Please also
    do not include any pornographic or non-work-safe images in your signature.








  16. #16
    Registered Member
    Location
    san martin, CA, United States
    Member No: 56117 bsrsystems is an unknown quantity at this point bsrsystems's Avatar
    Join Date
    Nov 2002
    Posts
    2,625
    Rep Power
    0


    Yes | No

    Re: Have to admit I bought a repacement too...

    I thought that she would just superglue you to the Jackallope for posterity...

  17. #17
    Registered Member
    Location
    Austin, TX, United States
    Member No: 18848 rwilli is an unknown quantity at this point rwilli's Avatar
    Join Date
    Nov 2001
    Posts
    117
    Rep Power
    0


    Yes | No

    Re: Who has original water pump??

    Installed the Stewart on my 2000M in 08; about a year later decided to go ahead with the Ireland aluminum radiator; installer called--said the Stewart was leaking--what!!!. Called Stewart--they replaced no questions asked--didn't have time to wait for it, so had the mechanic put in metal impellar OEM. Now have a new Stewart and will probably put it in down the road.--best laid plans, right.-- at least radiator is still ok.

  18. #18
    Registered Member
    Location
    Oceanside, CA, USA
    Member No: 149143 lpcapital is an unknown quantity at this point lpcapital's Avatar
    Join Date
    Jan 2007
    Posts
    2,437
    Rep Power
    0


    Yes | No

    Do you remember where was it leaking?

    Would be curious to know if it was the o-ring in which case could have been pinched in the first assembly or the actually bearing...
    ---------------------------------



    1998 Z3 1.9 - few modifications here and there
    1999 Z3 2.8 - individual edition (British Traditional)
    2003 Z4 2.5i


  19. #19
    Registered Member
    Location
    Austin, TX, United States
    Member No: 18848 rwilli is an unknown quantity at this point rwilli's Avatar
    Join Date
    Nov 2001
    Posts
    117
    Rep Power
    0


    Yes | No

    Re: Do you remember where was it leaking?

    The mechanic had pointed out that there was 'residue' around the weep hole. I took a picture and sent it to Stewart whereby they just sent a new one and I still have it for future change.

  20. #20
    Z3AtlBlu
    Guest
    Location
    , ,
    Member No: Z3AtlBlu's Avatar


    Yes | No

    Re: Who has original water pump??

    99 2.5 failed at just 0ver 75,000 mi. Took out the radiator, belts, hoses and shrouds. Was on the road away from home so had the dealer In Portland, OR. replace the parts with whatever they normally use. Rasmussen BMW, very nice folks. Got me going in about 4 1/2 hours (time from failure to back on the road, including towing time).

+ Reply to Thread
Page 1 of 2 1 2 LastLast


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum