+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Byron
    Guest
    Location
    , ,
    Member No: Byron's Avatar


    Yes | No

    82 733i will not shut off

    I recently had a problem with my ecu, and had to replace it. after replacing it, it ran great for a week, then one day it would not shut off. I had to dump the clutch to kill it. I replaced a corroded ground strap on the alternator, but it didn't solve it.

    The car seems to run great otherwise

    Thanks in advance for the input


  2. #2
    Registered Member
    Location
    , ,
    Member No: 171031 byrondw is an unknown quantity at this point byrondw's Avatar
    Join Date
    Jan 2009
    Posts
    9
    Rep Power
    0


    Yes | No
    It was the fuel pump relay, or rather the lack of one. Someone (not me) had put some random relay in where the fuel pump relay was supposed to be. Yesterday I found the Fuel pump relay in my glove box. The only thing I can figure is that the mechanic that I had it to last swapped them to diagnose my no start issue, and when I brought in my own ECU to replace the bad one, they either forgot, or didn't bother to put the correct relay back.
    Reply With Quote Reply With Quote 24.113.150.118

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum