+ Reply to Thread
Results 1 to 6 of 6
  1. #1
    Registered Member
    Location
    , ,
    Member No: 19678 j99t99 is an unknown quantity at this point j99t99's Avatar
    Join Date
    Nov 2001
    Posts
    84
    Rep Power
    0


    Yes | No

    Failed IDLE emissions 540i can PCV cause this?

    Just failed emissions for High HC during idle...(read 310ppm versus 220 standard at idle)[fyi, 170 ppm at high idle same standard). Originally it was reading about 580 ppm at both idle and high idle, but I replaced the driver side o2 sensor and the numbers dropped to what they are now. Previously I had removed my thermostat alltogether, so I suspected that the engine wasn't warm enough during low idle, therefore I installed a new thermostat and still have failing numbers. I do suspect my pcv could be changed due to some whistling/vacuum leak, but I am not sure this could cause this type of failure.

    Anyone have any suggestions? I searched the post and have no other ideas, except that I did replace my fuel pump over the summer and since then I have suspected that my fuel pressure might be too high...but that's another story, ask and I'll fill you in on that saga.Tim 95 540i 6spd


  2. #2
    Registered Member
    Location
    freehold, NJ, United States
    Member No: 13367 mac840 is an unknown quantity at this point mac840's Avatar
    Join Date
    Sep 2001
    Posts
    1,542
    Rep Power
    0


    Yes | No

    Re: Failed IDLE emissions 540i can PCV cause this?

    When were the plugs last changed? I failed for high hc with my 1993 525i. I changed the plugs and my hc went from 280 to 195. High hc is caused by unburnt fuel.

  3. #3
    Registered Member
    Location
    freehold, NJ, United States
    Member No: 13367 mac840 is an unknown quantity at this point mac840's Avatar
    Join Date
    Sep 2001
    Posts
    1,542
    Rep Power
    0


    Yes | No

    Also just before inspection get the cats red hot

    by driving for a while.

  4. #4
    Registered Member
    Location
    , ,
    Member No: 19678 j99t99 is an unknown quantity at this point j99t99's Avatar
    Join Date
    Nov 2001
    Posts
    84
    Rep Power
    0


    Yes | No

    Re: Failed IDLE emissions 540i can PCV cause this?

    I changed plugs when I changed the O2 sensor. I had stupidly put in those bosch platinum +4 plugs...holy crap what a mistake. I was thinking about unplugging my battery to reset my computer/dme. Tim 95 540i 6spd

  5. #5
    Registered Member
    Location
    , ,
    Member No: 19678 j99t99 is an unknown quantity at this point j99t99's Avatar
    Join Date
    Nov 2001
    Posts
    84
    Rep Power
    0


    Yes | No

    Re: Failed IDLE emissions 540i can PCV cause this?

    ok, i am getting forgetful in my old age. I just remembered about my MAF sensor. I stomp tested a while ago and came up with the 1215 MAF sensor code. I purchased a chinese made MAF for like $65 and it caused my car to stall. I never put it in. Come to realize that the reason my car was stalling was not the MAF, but my fuel pump was bad, not enough pressure. since then I still haven't put in the chinese made MAF. I'll try this next.
    Tim 95 540i 6spd

  6. #6
    Registered Member
    Location
    , ,
    Member No: 19678 j99t99 is an unknown quantity at this point j99t99's Avatar
    Join Date
    Nov 2001
    Posts
    84
    Rep Power
    0


    Yes | No

    Re: Failed IDLE emissions 540i can PCV cause this?

    Put in new MAF...codes clear. Bring on the state inspection. I noticed also that my mileage went from 12 to 16 city...not bad.Tim 95 540i 6spd

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum