+ Reply to Thread
Results 1 to 4 of 4
  1. #1
    95/540M
    Guest
    Location
    , ,
    Member No: 95/540M's Avatar


    Yes | No

    massive coolant leak....help please!

    I replaced my water pump a few weeks ago and everything was going great....until last night I got home from work and a cloud of smoke arose from under the hood as I parked. I refilled the tank this morning but to the point today when I got to work my car was near over heating, after a few hours of cooling off I went to add some more coolant mixture to the expansion tank. As I was pouring the coolant into the tank I heard the coolant leaking on to the ground. So I poured distilled water into the tank to try and track the leak but I could not see it any where. The only thing I can tell is that the water is falling from (within?)the engine around the bell housing/sway bar area but not anywhere above that I can see....
    Any help would be much appreciated.
    TIA
    Stephen


  2. #2
    Scott
    Guest
    Location
    , ,
    Member No: Scott's Avatar


    Yes | No

    Re: massive coolant leak....help please!

    As for the massive leak, at the firewall on the driver side is a small cover with several hoses running under it. There is a pump there that may be the culprit. Remove the 3 small clips from the cover and take a good look.
    As for the running water when you are filling the res., are you using a funnel or just pouring it in? There are holes for the overflow at the filler neck which may be the problem. The water/antifreeze will be leaking on the passenger side at the wheel well.
    Good luck.

  3. #3
    Gruss
    Guest
    Location
    , ,
    Member No: Gruss's Avatar


    Yes | No

    Re: massive coolant leak....help please!

    Are you sure you have all your hoses connected tight. Did you also replace the radiator hoses when you replaced your water pump. Stop driving your car before you overheat the engine and find out where the leak is.

  4. #4
    Stevo540
    Guest
    Location
    , ,
    Member No: Stevo540's Avatar


    Yes | No

    Re: massive coolant leak....help please!

    ohhhhhhhhh yeahh..... its the valley pan gasket. tore it all apart and thats my problem. i'm replacing all cooling gaskets and o-rigs while i'm down there so it should be all taken care of as soon as i get it back togehter.
    Thanks for the help

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum