+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Registered Member
    Location
    , , United States
    Member No: 160411 jim325e46 is an unknown quantity at this point jim325e46's Avatar
    Join Date
    Dec 2007
    Posts
    4
    Rep Power
    0


    Yes | No

    Heater heating in summer

    A 1/2 hour into a 3 hour trip this past weekend, I turned on the A/C in my 94 525 (w/200K miles) and felt hot air coming out the defrost vents. Despite having all temp settings to minimum and air controls closed, the heat continued in both vent and A/C modes. Searching archives, I could only find references to a lack of heat. Any suggestions on causes and/or search words?


  2. #2
    Registered Member
    Location
    freehold, NJ, United States
    Member No: 13367 mac840 is an unknown quantity at this point mac840's Avatar
    Join Date
    Sep 2001
    Posts
    1,542
    Rep Power
    0


    Yes | No

    your heater valves failed

    I had the same problem last week .The heater valves are stuck open allowing coolant into the heater core. New valve assembly is around $100 dollars online. The temp fix is to bypass the heater core by putting the hose from the aux water pump and the hose leading into the core together with a brass barbed coupling and hose clamps . This is what I did until I get a new valve. The only downside to this is the AC will blow full cold with no temperature control. This is not a problem with the weather lately!

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum