+ Reply to Thread
Results 1 to 3 of 3
  1. #1
    Registered Member
    Location
    Scottsdale, AZ, United States
    Member No: 163348 Jeff635Euro is an unknown quantity at this point Jeff635Euro's Avatar
    Join Date
    Mar 2008
    Posts
    90
    Rep Power
    0


    Yes | No

    No Fuel gauge, no tach., no temperature gauge

    Hello All,
    I apologize if this topic has been covered, I did not uncover anything by searching. My friend who owns the car thought it might be the ECU, but I don't have any reference material or experience to verify this.
    The car is a 1992 318i convertible (2/92), the last year of E30 convertible production. Basically, the only gauge working in the cluster is the speedometer. Possibly someone has experience with these symptoms.

    Thanks in advance,

    Jeff


  2. #2
    MACTAR!
    Guest
    Location
    , ,
    Member No: MACTAR!'s Avatar


    Yes | No

    ..no problem!

    just kidding, that's a problem.

    There are nuts on the back of the instrument cluster that provide grounding to the unit. They are something to investigate.

    Is the speedo working?

  3. #3
    Registered Member
    Location
    , ,
    Member No: 58646 jjcarr is an unknown quantity at this point jjcarr's Avatar
    Join Date
    Nov 2002
    Posts
    235
    Rep Power
    0


    Yes | No

    Re: No Fuel gauge, no tach., no temperature gauge

    Possibly the fuse. There is a 7.5amp fuse in the fuse-box in the engine bay that goes out once in a while, causes those symptoms.

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum