+ Reply to Thread
Results 1 to 2 of 2

Thread: rear shocks

  1. #1
    Registered Member
    Location
    , ,
    Member No: 183380 cruisingvessel is an unknown quantity at this point cruisingvessel's Avatar
    Join Date
    Sep 2010
    Posts
    2
    Rep Power
    0


    Yes | No

    rear shocks

    Hi. My rear shock mounts are bad ('95 525iT, meyle ones are crap parts) so I tried to take the assembly off to replace the mounts. I cannot get the lower shock mount off (where it attaches with a single bolt to the wheel assembly) for the life of me and have begun to destroy the shock in the process. Any thoughts / suggestions /solutions to this problem?


  2. #2
    Registered Member
    Location
    East Brunswick, NJ, United States
    Member No: 10712 yaofeng is an unknown quantity at this point yaofeng's Avatar
    Join Date
    Jun 2001
    Posts
    308
    Rep Power
    0


    Yes | No

    Re: rear shocks

    It is sprung I presume you have the rear on jacks and the wheel off. Remove the lone bolt (obviously). Spray sone liquid wrench between the contact surface of the shock and the hole. Use a big, no huge, flat blade screw driver to pry it off.





    AIM: yaofeng4249
    '95 525i 5 speed built 5/94 w/93 m50tu engine
    '94 540it built 3/93, converted to 6 speed w/a '93 e32 M60, 4.0L Nikasil engine
    '01 540it, built 6/01
    '03 325i 5 speed, built 9/02
    '10 mini 6 speed

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum