+ Reply to Thread
Results 1 to 5 of 5

Hybrid View

  1. #1
    Registered Member
    Location
    Bekasi, , Indonesia
    Member No: 167585 ETobing is an unknown quantity at this point ETobing's Avatar
    Join Date
    Sep 2008
    Posts
    68
    Rep Power
    0


    Yes | No

    Exclamation Sign (?)

    Dear all,

    Once again for the second time -the first was last year-- I have this exclamation mark sign on. I have searched on the owner's manual it says the sign indicates hydraulic-brake issue. Last year I replaced all four (front & rear) caliper rubber seal and it indeed solved the problem.

    This time however is different. I have recently replaced all four discs, brake-pads, and brake fluid. The system worked fine for couple of days before the sign on. Although I have dismantled front caliper: clean the piston and the seal it just didn't turn the lamp off.

    Any advice on this? Should I replace the caliper seal which makes me wonder it was good for a year only? Thanks for the response.

    Rgds,

    Rgds,
    Enrico Tobing

    528i E39 1997
    Automatic ZF 5HP18

  2. #2
    Craig in Canada
    Guest
    Location
    , ,
    Member No: Craig in Canada's Avatar


    Yes | No

    Re: Exclamation Sign (?)

    Is it red or yellow?

    Red means a problem in the system - like low brake fluid.

    Yellow means a brake pad wear sensor (or its circuit) has tripped.


  3. #3
    Enrico Tobing
    Guest
    Location
    , ,
    Member No: Enrico Tobing's Avatar


    Yes | No

    It's red but brake fluid level is correct.

    any other possibility? FYI, I replaced both short hose from ABS module few days ago. Could this be the cause?

    Enrico Tobing
    528i/E39/1997

  4. #4
    Craig in Canada
    Guest
    Location
    , ,
    Member No: Craig in Canada's Avatar


    Yes | No

    Re: It's red but brake fluid level is correct.

    Are the wires hooked back up to the reservoir cap? If you remove the cap and slide the float up by hand will the red ! clear? What about if you close the contacts on the connector with a paper clip?

    I don't know if there are any tests which bring on only the red brake warning light other than fluid level. If you had a lot of other lights (like ABS and traction control) that speaks to a larger problem.


  5. #5
    Registered Member
    Location
    Bekasi, , Indonesia
    Member No: 167585 ETobing is an unknown quantity at this point ETobing's Avatar
    Join Date
    Sep 2008
    Posts
    68
    Rep Power
    0


    Yes | No

    Re: It's red but brake fluid level is correct.

    Thanks again Craig but the sign was off this afternoon. Honestly I am not sure why but I replaced the damaged brake pad sensor yesterday morning, the red sign was still on the whole day and it turned off just like that this morning when I started the engine.

    I still have to learn a lot about this car that's for sure. For example I thought the brake pad sensor was supposed to trigger the brake pad sign, not the red "!" sign.

    Rgds,

    Rgds,
    Enrico Tobing

    528i E39 1997
    Automatic ZF 5HP18

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum