+ Reply to Thread
Results 1 to 3 of 3

Thread: HVAC issues

Hybrid View

  1. #1
    MarkD
    Guest
    Location
    , ,
    Member No: MarkD's Avatar


    Yes | No

    HVAC issues

    Recently the driver-side temperature control on my HVAC stopped working. Itís all hot, all the time; doesn't matter where you spin it to. Then a few days later, it started working again, and has been intermittent ever since (mostly NOT working).

    Soon after that first event, the rear defroster button quit lighting up (and the defroster was not working). Now it, too, is intermittent and mostly NOT working.

    Could these two problems be caused by the same failing component in the HVAC system? Trying to figure out what the component might be, what it would cost, and whether I could replace it myself. Thanks.

  2. #2
    bonzo
    Guest
    Location
    , ,
    Member No: bonzo's Avatar


    Yes | No

    Re: HVAC issues

    There is a climate control module that could cause both of your problems. It should be located behind the heater plenum. It could be a loose wire/connection from the module to the air drier unit and then to the DME, or the control module itself could be going south. I'm assumeing you have checked your relays and ALL fuses. Not sure what year your 34 is but there are 4-5 different climate control modules, depending on the year and DME version.

  3. #3
    MarkD
    Guest
    Location
    , ,
    Member No: MarkD's Avatar


    Yes | No

    Re: HVAC issues

    Thanks, I will look into that.

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum