+ Reply to Thread
Results 1 to 17 of 17

Hybrid View

  1. #1
    blodi
    Guest
    Location
    , ,
    Member No: blodi's Avatar


    Yes | No

    Low Idle and now stalling....98 528i

    My 98 528i started having idle issues the other day after I came out to start it and the battery was dead. I charged the battery and was able to start it, but it was idling really low 3-400rpm. This morning I came out and the battery was dead again. I was able to jump it and drive it and pick up a new battery for it. I replaced the battery, but the idle is still really low and rough.
    I took out the ICV and cleaned it, it didn't look too bad. I put it all back together and it was no different, still low idle. I took it for about a 1 mile drive and now it won't even hold an idle as I was coming back, it runs fine if I keep my foot on the gas, but won't hold an idle itself.
    Any thoughts? I disconnected the battery to see if maybe that will reset the ecu....maybe the ICV is just shot?
    It just seems strange that its been fine before the battery went dead.
    Any help is appreciated.


  2. #2
    Ken....
    Guest
    Location
    , ,
    Member No: Ken....'s Avatar


    Yes | No

    Is the CEL on?


  3. #3
    blodi
    Guest
    Location
    , ,
    Member No: blodi's Avatar


    Yes | No

    Re: Is the CEL on?

    Just came on....
    Got "Idle speed not plausable" and "Air Mass Sensor"

    I replaced the MAF back in the spring. It was idling rough and shifting really rough. Maybe that's it? I tried putting the original MAF back in just now and there was no diff. It was an aftermarket MAF I bought, so maybe it already went bad?


  4. #4
    Blodi
    Guest
    Location
    , ,
    Member No: Blodi's Avatar


    Yes | No

    Also...

    Just tried to start with maf disconnected. Still won't idle and reved a little rougher. Also the car will not start unless i am giving it gas.

  5. #5
    Registered Member
    Location
    Pembroke, MA, United States
    Member No: 4328 jimlev will become famous soon enough jimlev will become famous soon enough jimlev's Avatar
    Join Date
    Oct 2000
    Posts
    19,983
    Rep Power
    36


    Yes | No

    Make sure none of the air tubes/hoses R cracked






    "Drive It Like You Stole It, A Sickness for Quickness"
    The Bottle Rocket "King of Spray" 2 Stage Nitrous Oxide
    Dare to be different and stand out among the crowd of me-to-cars!
    No guts, no glory! Tire smoke, not traction control!
    Zionsville all aluminum radiator to replace the 3 leak prone Nissens Radiators!

    NOS Progressive 2 Stage Controller with port injection
    Snow's Performance Methanol/Water Injection
    Dinan downloads, VAC Under Drive Pulleys
    Dinan Carbon Fiber CAI
    Dinan Front Strut Bar
    Electric Cooling Fan w/PWM controller
    NGK Iridium Plugs
    DDE Enhanced Angel Eyes, Smoked Lenses
    Koni FSD's/H&R Springs, BAV Brass Caliper Bushings
    Eisenmann Race Exhaust (from H8-Rain's car)
    ///M5 3.15 LSD
    ///M5 Sway Bars, Front & Rear
    Energy Suspension Polyurethane Sway Bar Bushings
    ///M5 Gauge Cluster Rings ///M5 Lip Spoiler
    ///M5 Mirrors and Switches
    Leather Z weighted shift knob (thanks H8-Rain)
    Rogue “Octane” Short Shift kit w/WSR
    Rogue Tranny Mounts
    StopTech Brake Lines Front & Rear
    Axxis Deluxe Plus pads Front & Rear
    Staggered M Parallel 66, Xenons
    Modified CDV, UGDO
    Euro Storage Tray (thanks Zombywolf)
    Redline in Diff and Tranny
    Passport 8500 X50, Escort ZR3 Laser Jammer
    G-Tech/Competition Pro Data Logger
    Auto Enginuity OBD-II Scan Tool
    25% Tint, X-Pel, LoJack
    PIAA Driving Lights
    BMW CCA Member Boston Chapter

  6. #6
    Blodi
    Guest
    Location
    , ,
    Member No: Blodi's Avatar


    Yes | No

    I did spray some tb cleaner around....

    Looking for leaks.....nothing.

  7. #7
    E39_Silver
    Guest
    Location
    , ,
    Member No: E39_Silver's Avatar


    Yes | No

    What are the P0 codes. This doesnt sound like....

    something that happened overnight. You have a new battery (consider unrelated), I would take a look at your intake manifold gaskets, since you say you have fairly new MAF and start from there back to the intake gaskets and all vacuum lines. From personal experience I was unable to find these leaks with the old "spray TB cleaner and see if RPM go up/high". And also can you hear the ICV "humm" when you open the ignition switch?

  8. #8
    Ken....
    Guest
    Location
    , ,
    Member No: Ken....'s Avatar


    Yes | No

    Re: Is the CEL on?

    I had an aftermarket MAF go bad on me after a few months.

    Also check the air intake boot.

    Ken....

  9. #9
    Registered Member
    Location
    Cheshire, CT, United States
    Member No: 104565 Zardoz2025 is on a distinguished road Zardoz2025's Avatar
    Join Date
    Mar 2004
    Posts
    1,647
    Rep Power
    14


    Yes | No

    Re: Low Idle and now stalling....98 528i

    Did you do these things when you disonnected the battery to reset the ECU:

    1. open trunk and wait :16 minutes until car goes into sleep mode (trunk light will go out)
    2. disconnect the neg terminal cable, then the positive terminal cable
    3. touch the disconnected CABLES together while turning the ignition on for 15 seconds (this will disipate any residual power in the systems
    4 reconnect the pos cable to the battery, then the neg cable

    Might be worth a shot. A low battery can cause all sorts of funny electrical gliches.
    Ed CT
    1998 528i (aka, best car I ever owned!)
    5-Speed
    Aspen Silver
    Aubergine Leather
    Zeckhausen CDV
    Nokia CK-7
    D-Con Cache on Fuel Pump Cover

  10. #10
    Blodi
    Guest
    Location
    , ,
    Member No: Blodi's Avatar


    Yes | No

    Thanks for the steps ED...tried em...no luck,

    My new MAF is supposed to get here tomorrow, so hopefully that does the trick. I appreciate the suggestion though,

  11. #11
    Craig in Canada
    Guest
    Location
    , ,
    Member No: Craig in Canada's Avatar


    Yes | No

    Re: Thanks for the steps ED...tried em...no luck,

    I haven't had a MAF go bad on my M52, but from everything I've read if the problem is the MAF then disconnecting it will fix the symptoms. From what you've described, it doesn't. Perhaps you'll get lucky - please let us know.


  12. #12
    Registered Member
    Location
    Cheshire, CT, United States
    Member No: 104565 Zardoz2025 is on a distinguished road Zardoz2025's Avatar
    Join Date
    Mar 2004
    Posts
    1,647
    Rep Power
    14


    Yes | No

    Re: Thanks for the steps ED...tried em...no luck,

    If the new MAF doesn't do it, and you don't find any leaks, it could be the camshaft position sensor. A bad one will cause rough idle and stalling. BUT, read the CEL code first to get pointed to the system that has the fault.
    Ed CT
    1998 528i (aka, best car I ever owned!)
    5-Speed
    Aspen Silver
    Aubergine Leather
    Zeckhausen CDV
    Nokia CK-7
    D-Con Cache on Fuel Pump Cover

  13. #13
    Craig in Canada
    Guest
    Location
    , ,
    Member No: Craig in Canada's Avatar


    Yes | No

    Re: Thanks for the steps ED...tried em...no luck,

    Blodi: M52 or M52TU engine (what's your date code in 1998)?

    On my M52, when my camshaft sensor went at first the only thing I noticed was the CEL. After that, and with it disconnected, the only thing happening was that VANOS wasn't active. In this state it was gutless, but if you were just driving sedately around town you might not even notice the difference.

    I'm not sure how the double VANOS M52TU might react differently. I think it's a much more serious issue with double VANOS engines when these sensors don't operate correctly since both cams are adustable.


  14. #14
    blodi
    Guest
    Location
    , ,
    Member No: blodi's Avatar


    Yes | No

    *UPDATE* FIXED!

    It was the MAF. Put the new one in and it took it about 10 sec or so for the ECU to readjust, but just took it out on a test drive and its running good as ever. Thanks for all the suggestions and help guys!
    To answer a question its the single vanos M52.
    I guess the moral here is, don't buy cheap MAF's!


  15. #15
    Craig in Canada
    Guest
    Location
    , ,
    Member No: Craig in Canada's Avatar


    Yes | No

    Good to hear!


+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum