+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Registered Member
    , ,
    Member No: 184259 Jstncspin is an unknown quantity at this point Jstncspin's Avatar
    Join Date
    Dec 2010
    Rep Power

    Yes | No

    1994 BMW E34 Belt issue? Help!

    I've got a 1994 BMW 540i with 139k on it! When I bought it I had some generic shop put new belts on. They put belts that were too small on and caused the water pump to prematurely fail. I replaced the water pump and put contitech oem belts on. It started making a ticking noise. Also when I would turn the wheel all the way to the left it would jump back and the power steering reservoir would jerk. The new serpentine belt eventually came off two weeks after it was put one and was starting to fray. The power steering pump seems to be ok, it hasn't seized up. Inwas low on power steering fluid however. Any ideas or help is appreciated. I though maybe the steering is having an issue or maybe the tensioners?

  2. #2
    , ,
    Member No: bonzo's Avatar

    Yes | No

    Re: 1994 BMW E34 Belt issue? Help!

    It could be a bad pully. On that engine, there should be three. When the pully starts to go south they will make a ticking sound. Also check and make sure the pully on your water pump is still in alignment with the rest. A belt that is too small can cause premature wear and missalignment of the others.

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)



Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum