+ Reply to Thread
Results 1 to 5 of 5
  1. #1
    Registered Member
    Location
    New Hartford, CT, United States
    Member No: 97754 nealyates is an unknown quantity at this point nealyates's Avatar
    Join Date
    Jan 2004
    Posts
    8
    Rep Power
    0


    Yes | No

    533i engine quits without warning

    1985 533i 5-speed w/188k will drive around all day, local roads and interstates, then suddenly (and this sounds weird, I know) will simply quit running as I take a right-hand turn and downshift. 3 out of 3 times. Engine doesn't cough, hesitate, backfire or anything - just stops like someone threw a switch. Engine will turn over, all electrics working, but it will not start. Had it towed four times in last six weeks. Each time it's towed, the mechanic goes out to check and car starts right up. Mechanics in two places said it might be a bad crank sensor. Had a pair put in last week. Two days ago, I had pulled into a parking place (by turning right) in a mall. Came out from the store - car would not start. Car towed. Next morning, started right up. Any thoughts?


  2. #2
    Registered Member
    Location
    , ,
    Member No: 58142 ROYinGA is an unknown quantity at this point ROYinGA's Avatar
    Join Date
    Nov 2002
    Posts
    2,633
    Rep Power
    0


    Yes | No

    Have you replaced the main relay?


  3. #3
    Registered Member
    Location
    New Hartford, CT, United States
    Member No: 97754 nealyates is an unknown quantity at this point nealyates's Avatar
    Join Date
    Jan 2004
    Posts
    8
    Rep Power
    0


    Yes | No

    Re: Have you replaced the main relay?

    Hi. Roy. Thanks for the reply. Replaced the Main relay and the Fuel Pump relay yesterday. I broke into the old ones and no signs of anything amiss, so I'm wary of that being the solution. I just don't want to get stuck next time on Christmas morning!

    Problem is, car runs smooth and strong until, without warning, it simply stops running. Tow it and try it, and it fires up great. This is the fourth time.

    Could it be vapor lock? I know it's winter and CT is not high elevation, but can something else cause it? While some 533i have two fuel pumps (low pressure in-tank and the external main pump), some don't. Mine, an '84, doesn't. Just the external main pump. If something vaporizes the fuel between the tank and pump (or maybe just introduces air into the line), it might stall the engine and make it difficult to start immediately, right? But give it a rest (such as waiting for AAA) and all is well again. Makes any sense?

  4. #4
    Rick in MI
    Guest
    Location
    , ,
    Member No: Rick in MI's Avatar


    Yes | No

    Re: 533i engine quits without warning

    Have you tried bending the armature that rides on the circuit board for the air flow unit? Pry off the black cover and gently change the path even so slightly. Check the archive about this.

    Rick
    '87 535is, 305k

  5. #5
    Registered Member
    Location
    , , United States
    Member No: 184487 dave72 is an unknown quantity at this point dave72's Avatar
    Join Date
    Jan 2011
    Posts
    1
    Rep Power
    0


    Yes | No

    Re: 533i engine quits without warning

    hi i had the same simptons on my 535i i changed every think sensor wise in the end it was the ECU,i take it when it won't start it keeps turning over and over.if this is the case check the number one HT lead to see if you got a spark and that you getting fuel to the fuel rail no spark or fuel then the ECU knacked,only check this when the car isn't working
    cheers dave

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum