+ Reply to Thread
Results 1 to 4 of 4
  1. #1
    Rick Z
    Guest
    Location
    , ,
    Member No: Rick Z's Avatar


    Yes | No

    How is alternator grounded

    Hi all. I recently did an engine overhaul on myí85 535i, and when I put it back together found that the battery wasnít charging - no output from the alternator which I had had rebuilt at an alternator shop. At first I thought the shop had put in the wrong regulator, but after checking further I started to look at the charging circuit, which is pretty simple, and it got me wondering about how the alternator is grounded. I know the engine is supposed to be grounded with a small strap from the back of the head to the frame, but the alternator itself is isolated from the engine with the mounting bolts running through rubber vibration bushings - there is no metal contact between the alternator body at all and I donít see how there ever could have been, but if that was true the car would never run properly right from the factory! Did I miss something when I put the engine back together? There is no ground connection on the alternator body, but Iím thinking of running one directly to the battery negative terminal. Any ideas? Thanks.


  2. #2
    Registered Member
    Location
    , ,
    Member No: 58142 ROYinGA is an unknown quantity at this point ROYinGA's Avatar
    Join Date
    Nov 2002
    Posts
    2,633
    Rep Power
    0


    Yes | No

    Mine has a fat brown wire screwed to the back of

    the case and then to the mounting casting on the engine.

  3. #3
    Steve B
    Guest
    Location
    , ,
    Member No: Steve B's Avatar


    Yes | No

    The later alts-

    didn't have rubber bushings, so they were grounded through the mounts. The earlier ones used rubber bushings and a ground strap. So, for 88 you should have the solid mounts, but since you don't, add the ground wire.

  4. #4
    Rick Z
    Guest
    Location
    , ,
    Member No: Rick Z's Avatar


    Yes | No

    Thanks

    Thanks guys. Sorry for taking so long to notice your responses. There was indeed supposed to be a ground strap that I forgot to replace when I put the alternator back. I was looking at a pre-disassembly picture when I noticed it. No wonder my battery wasn't charging.
    Reply With Quote Reply With Quote 23.16.103.146

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum