+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Registered Member
    Location
    , ,
    Member No: 129116 drmaniquiz is an unknown quantity at this point drmaniquiz's Avatar
    Join Date
    Jul 2005
    Posts
    54
    Rep Power
    0


    Yes | No

    Resilient 'Check Engine Light' after CS replaced

    I've got a '98 528i sport and my check engine light went on. I ran my diagnostic tool and it read code P340 (Camshaft Sensor). I replaced it, which wasn't easy getting it connected underneath my headers then I reset the check engine light. It went off, but when I started driving again, it went back on.

    My question is what's going on? What else could it be?


  2. #2
    Inner Circle Member Inner Circle Member
    Location
    San Jose, CA, United States
    Member No: 21320
    Inner Circle ©155 since: Jul 21, 2003 edjack will become famous soon enough edjack's Avatar
    Join Date
    Dec 2001
    Posts
    8,640
    Rep Power
    23


    Yes | No

    Possible dirty or fouled connector. If you bought>

    the CPS on ebaY, that's the second possibility.
    Ed in San Jose. BMW CCA member since 1987 (Nr. 62319). Golden Gate Chapter. '97 540i 6 speed. Build Date 3/97. Aspensilber over Aubergine leather.

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum