+ Reply to Thread
Results 1 to 3 of 3
  1. #1
    Homer
    Guest
    Location
    , ,
    Member No: Homer's Avatar


    Yes | No

    Update-Re Ice Storm Overheat

    I wanted to give the solution found to my overheating problem which I posted about back on Feb.2 but I cant do it on the old thread. The car needed a water pump. Id have never guessed that as it seemed to be related to sitting at idle or traveling slow in snow. Thanks to all here that contributed. Love these forums.


  2. #2
    Inner Circle Member Inner Circle Member
    Location
    San Jose, CA, United States
    Member No: 21320
    Inner Circle ©155 since: Jul 21, 2003 edjack will become famous soon enough edjack's Avatar
    Join Date
    Dec 2001
    Posts
    8,640
    Rep Power
    23


    Yes | No

    Was the impeller deteriorated?


    Ed in San Jose. BMW CCA member since 1987 (Nr. 62319). Golden Gate Chapter. '97 540i 6 speed. Build Date 3/97. Aspensilber over Aubergine leather.

  3. #3
    Homer
    Guest
    Location
    , ,
    Member No: Homer's Avatar


    Yes | No

    Re: Was the impeller deteriorated?

    Right now I dont know the details--not sure what the mechanic knows about it inside. I am going to ask more when I get the chance.

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum