+ Reply to Thread
Results 1 to 13 of 13
  1. #1
    Registered Member
    Location
    Pico Rivera, CA, United States
    Member No: 86073 bimmer530 is an unknown quantity at this point bimmer530's Avatar
    Join Date
    Aug 2003
    Posts
    146
    Rep Power
    0


    Yes | No

    Service Engine Soon Light is on????

    Hello there, My Service Engine Soon light is on, engine runs roughly right now. Please need help on what to do. Can I drive this one to a shop or just tow it to the shop to be safe.
    It started when my oil warning light on then off. Then I park the car in my garage for three days. when I start the car "Service Engine Soon" lights turn on. Idling is kinda rough.
    Do you guys think it might be the MAF sensor or something else. Please need help.
    Thanks to all.
    Reply With Quote Reply With Quote 98.112.11.172


  2. #2
    Registered Member
    Location
    , NY,
    Member No: 172507 VinM is an unknown quantity at this point VinM's Avatar
    Join Date
    Mar 2009
    Posts
    455
    Rep Power
    0


    Yes | No
    First, check your oil level.

    Was the oil light yellow or red? If it was yellow, then most likely you're low on oil (or the oil level sensor may have gone bad), if it was red, then that indicates low oil pressure, and you may have a more serious problem...in that case, I reccomend towing it to the shop...you don't want to run the engine without adequate oil pressure.

    You need to scan for codes to see what's triggering the SES light.
    2003 530i (Sport Package) Build Date: 02/03
    Titanium Gray over Black
    Shadowline Trim
    5-Speed Manual Transmission
    Zeckhausen Modified CDV
    Dinan Upgrades: High Flow Throttle Body, CAI, Stage 3 Software, and Free Flow Exhaust.

    Horsepower: some is good, more is better, TOO MUCH is just right!
    "If everything seems under control, you're just not going fast enough." ~ Mario Andretti
    "What’s behind you doesn’t matter." ~ Enzo Ferrari
    Reply With Quote Reply With Quote 71.125.245.120

  3. #3
    Registered Member
    Location
    , , Canada
    Member No: 175547 JimCash is an unknown quantity at this point JimCash's Avatar
    Join Date
    Aug 2009
    Posts
    321
    Rep Power
    0


    Yes | No
    To answer you question if we think "it might be the MAF sensor or something else" - YES.

    But the "else" can be many things. There are "hundreds" of faults that can set off the warning lamp - so it is not possible for anyone to "guess" what it is.
    If you have been getting an oil pressure lamp then I would get this seen by a service centre ASAP - but if the oil pressure lamp is not on when you start it then you can probably drive it there.

    Cheers
    Jim Cash
    Reply With Quote Reply With Quote 70.27.62.107

  4. #4
    Inner Circle Member Inner Circle Member
    Location
    San Jose, CA, United States
    Member No: 21320
    Inner Circle ©155 since: Jul 21, 2003 edjack will become famous soon enough edjack's Avatar
    Join Date
    Dec 2001
    Posts
    8,640
    Rep Power
    23


    Yes | No
    You don't tell us the model year or build date, or the model, or how many miles are on the car. We can't give you good advice w/o this info.


    Ed in San Jose '97 540i 6 speed aspensliber over aubergine leather. Build date 3/97. Golden Gate Chapter BMW CCA Nr 62319.
    Reply With Quote Reply With Quote 68.164.80.136

  5. #5
    Registered Member
    Location
    Pico Rivera, CA, United States
    Member No: 86073 bimmer530 is an unknown quantity at this point bimmer530's Avatar
    Join Date
    Aug 2003
    Posts
    146
    Rep Power
    0


    Yes | No
    Oops my bad, It's a 2001 BMW 530i / Automatic / Sports package / with 80,000 miles now.
    Not sure if I want to drive this for 20 miles to a shop. I check the dip stick and looks like i don't have oil in the pan.
    I put one liter and show level on the first line. Then I start it, seems that engine is running a little rough, no oil warning light indicator on, just "Service Engine Soon". Don't know how much will this one cost.
    Thanks,
    Reply With Quote Reply With Quote 98.112.11.172

  6. #6
    Registered Member
    Location
    Cheshire, CT, United States
    Member No: 104565 Zardoz2025 is on a distinguished road Zardoz2025's Avatar
    Join Date
    Mar 2004
    Posts
    1,647
    Rep Power
    14


    Yes | No
    Quote Originally Posted by bimmer530 View Post
    I check the dip stick and looks like i don't have oil in the pan.
    I put one liter and show level on the first line. .
    Thanks,
    Your engine is low (or extremely low!) on oil. The oil level should always be up to the proper mark on the dipstick. You should add enough oil to get it to that mark, Hopefully no serious damage was done to the engine. The oil level should be checked AT LEAST once a week or every time you put in gas. Many on the board here have noted that their 530s use up oil, and need oil top-ups in between changes.


    Quote Originally Posted by bimmer530 View Post
    Then I start it, seems that engine is running a little rough, no oil warning light indicator on, just "Service Engine Soon". Don't know how much will this one cost.
    Thanks,
    The rough idle may or may not be related to the low oil issue. You need to have the code read to know what system is at fault - this is where the diagnosis begins. Some of the local auto parts stores will read the code for you. Or, take it to your mechanic and have him do the diagnosis. There's no way to tell at this point how much it will cost without a proper diagnosis of the problem.
    Ed CT
    1998 528i (aka, best car I ever owned!)
    5-Speed
    Aspen Silver
    Aubergine Leather
    Zeckhausen CDV
    Nokia CK-7
    D-Con Cache on Fuel Pump Cover
    Reply With Quote Reply With Quote 75.150.83.190

  7. #7
    Inner Circle Member Inner Circle Member
    Location
    San Jose, CA, United States
    Member No: 21320
    Inner Circle ©155 since: Jul 21, 2003 edjack will become famous soon enough edjack's Avatar
    Join Date
    Dec 2001
    Posts
    8,640
    Rep Power
    23


    Yes | No
    Don't these I6s have oil level sensors? My V8 does.

    Perhaps it's a failed sensor.


    Ed in San Jose '97 540i 6 speed aspensliber over aubergine leather. Build date 3/97. Golden Gate Chapter BMW CCA Nr 62319.
    Reply With Quote Reply With Quote 68.164.80.136

  8. #8
    Registered Member
    Location
    , ,
    Member No: 21537 sktn77a is an unknown quantity at this point sktn77a's Avatar
    Join Date
    Dec 2001
    Posts
    1,226
    Rep Power
    0


    Yes | No
    Yes, they do have a low oil level sensor but it usually triggers a "Engine Oil Low" message, not the CEL. I'm guessing one problem is that the CVV is plugged.
    Keith
    2001 530i 5sp
    Reply With Quote Reply With Quote 66.57.23.251

  9. #9
    Registered Member
    Location
    Cheshire, CT, United States
    Member No: 104565 Zardoz2025 is on a distinguished road Zardoz2025's Avatar
    Join Date
    Mar 2004
    Posts
    1,647
    Rep Power
    14


    Yes | No
    Yes, there's a "Low Oil" yellow light that comes up on the instr. cluster AFTER the engine is turned off. If the driver isn't paying attention, it could be missed.
    However - and I've never had my oil this low, so I'm assuming here - there has to be a RED instrument cluster idiot light that goes on while the engine is running if the oil level is dangerously low. So, yes , maybe it is a bad sensor.

    I'm hoping that the thread author here keeps us aprised as to the resolution and possible causes, if known. It'd be nice to know if a preventive measure on the oil level sensor is waranted!
    Ed CT
    1998 528i (aka, best car I ever owned!)
    5-Speed
    Aspen Silver
    Aubergine Leather
    Zeckhausen CDV
    Nokia CK-7
    D-Con Cache on Fuel Pump Cover
    Reply With Quote Reply With Quote 68.109.18.11

  10. #10
    Registered Member
    Location
    , ,
    Member No: 21537 sktn77a is an unknown quantity at this point sktn77a's Avatar
    Join Date
    Dec 2001
    Posts
    1,226
    Rep Power
    0


    Yes | No
    Actually, my low engine oil warning came on once after an oil change where they had put about 1qt too little oil. So ordinarily this should come on before any dangerous condition is reached. The warning does come on when you turn the key off but there's an audible (chime) warning too.
    Keith
    2001 530i 5sp
    Reply With Quote Reply With Quote 66.57.23.251

  11. #11
    Registered Member
    Location
    Cheshire, CT, United States
    Member No: 104565 Zardoz2025 is on a distinguished road Zardoz2025's Avatar
    Join Date
    Mar 2004
    Posts
    1,647
    Rep Power
    14


    Yes | No
    Quote Originally Posted by sktn77a View Post
    Actually, my low engine oil warning came on once after an oil change where they had put about 1qt too little oil.
    Keith - did you get the warning while the engine was running? Or only after you shut her down?
    And, now that you mentioned it, I do remember hearing the chime, too.
    Ed CT
    1998 528i (aka, best car I ever owned!)
    5-Speed
    Aspen Silver
    Aubergine Leather
    Zeckhausen CDV
    Nokia CK-7
    D-Con Cache on Fuel Pump Cover
    Reply With Quote Reply With Quote 68.109.18.11

  12. #12
    Registered Member
    Location
    , ,
    Member No: 21537 sktn77a is an unknown quantity at this point sktn77a's Avatar
    Join Date
    Dec 2001
    Posts
    1,226
    Rep Power
    0


    Yes | No
    After turning the engine off.
    Keith
    2001 530i 5sp
    Reply With Quote Reply With Quote 66.57.23.251

  13. #13
    Registered Member
    Location
    Pico Rivera, CA, United States
    Member No: 86073 bimmer530 is an unknown quantity at this point bimmer530's Avatar
    Join Date
    Aug 2003
    Posts
    146
    Rep Power
    0


    Yes | No
    I did get the warning light when I was parking. I turn off the engine, wait for 30 seconds the start it again, the oil warning light gone. Then I go home and put it in the garage since I am going to use the small car. After 3 days, getting ready to go to work early morning, I start the car, oh no.., engine running roughly. Try to keep it for 2 min., still idling roughly, try to backup out of the garage, still running rough. The next day I change the oil, found I still have 4 liters on the car. Put new oil, filters.. Start it again still running rough, I drove it around our block. Still running rough. Next week I have an appointment at the shop, should I tow it or just drive the car carefully to the shop (20 miles). Please need advice. Thanks to all of you.
    Reply With Quote Reply With Quote 98.112.11.172

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Yellow Service Engine Soon light is ON- any ideas?
    By JimP in forum BMW Z3 Coupe Forum & M Coupe Forum (E36, E38)
    Replies: 3
    Last Post: 12-09-2002, 08:10 PM
  2. Service Engine Soon light is on! I checked the
    By barb.stopinski in forum BMW 3 Series Forum (E46)
    Replies: 3
    Last Post: 11-14-2002, 10:08 AM
  3. "Service Engine Soon" light is on...(m)
    By Ashok in forum BMW 5 Series Forum (E39)
    Replies: 0
    Last Post: 10-21-2001, 11:04 AM
  4. "Service Engine Soon" Light is ON
    By Addy in forum BMW 5 Series Forum (E39)
    Replies: 6
    Last Post: 07-29-2001, 03:02 PM

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum