+ Reply to Thread
Results 1 to 8 of 8
  1. #1
    User Level 1
    Location
    , ,
    Member No: 187220 heinekenhk is an unknown quantity at this point heinekenhk's Avatar
    Join Date
    Jul 2011
    Posts
    1
    Rep Power
    0


    Yes | No

    Transmission warning light

    Hi , I've a trobule with my 99" E46 323ci...

    Since one year ago, sometimes "Transmission warning light" shows on dashboard when I stopped the car by brake, and it goes to limp mode (locked to 3th /4th gear),

    the car seems very heavy and needs alot amount of fuel to let the car start to run, I needed to switch off the engine and wait for 5 seconds then re-start it again, at the mean time TURN OFF A/C, it resume normal. but if I don't turn off A/C it'll (maybe) lights up again .

    I found that everytime when the warning light on MUST with these 2 situation :
    - stopped the car by brake (for example: stop @ red traffic lamp, traffic jam ..) and shift was in position "D",
    - The air-conditioner was on.


    "the warning light never shows up when NO Air-Con. and no matter how many times I stop the car (e.g. traffic jam) and the gear box looks quite normal and smooth"

    I have drove my car to many garages to read fault code, both readers only shows 1 fault "fault codes FC 059 (3B) Stall speed plausibility" in the A/T.

    I have checked the battery and alternator, it seems normal, thus the garage help me to change Transmission fluid as adviced, but it still the same..

    Few months later, I found an expert in BMW garage to help, the engineer use "GT1" to monitor the system and had a road test, he said my tranny too hot compare with engine, when tranny reach 115C, warning light on, thus he ask me to replaced whole cooling system (water tank, water pump, heat exchanger, radiator, water pipes ...etc ) and go out to have a road test, but the PROBLEM STILL THE SAME!!

    "Turn A/C on, run for a while and stop the car by brake in shift postion D, wait few second, the warning light (will / maybe) on"

    My fd told me maybe my TCM - Transmission Control Module (EGS) was fault, thus the engineer help me to borrow a EGS from another 323i, and plug to my car go for a test, but the PROBLEM STILL THE SAME!!

    and thus the engineer assume my tranny need to re-build !!!


    BUT, some garage said it was not the tranny's problem, coz warning light only shows when A/C on...


    (but the warning lights shows on not very often, with A/C was on, sometimes I can drove whole day but sometimes only when I leaving car park )


    Also Do anyone know what happened to my car ?? many thanks !!!
    Reply With Quote Reply With Quote 118.143.12.52


  2. #2
    Unregistered
    Guest
    Location
    , ,
    Member No: Unregistered's Avatar


    Yes | No

    Transmission warning light

    Hi, did you ever get this resolved. I have a very simliar problem and just replaced the battery. It happened 1 more time after that, so I did a little more research. My reserach led me turning the car on and off 6 times. It's been a day now since i cycled the power 6 times and it hasn't returned - but too soon to tell.
    Reply With Quote Reply With Quote 24.63.186.90

  3. #3
    Unregistered
    Guest
    Location
    , ,
    Member No: Unregistered's Avatar


    Yes | No
    Hi,

    Did the on/off 6 times work for you? I have the same issue. My indie mechanic doesn't know what it is but he suspects something is causing an irregular voltage which trigers the warning light. Battery, alternator are all fine. No aftermarket other than angel eyes which I've had for 4 years and never had this issue before. Car does not go into limp mode amd gears shift fine but (!) indicator comes on and off. This started right before water pump died out but this was replaced and the indicator still comes on. Thanks!
    Reply With Quote Reply With Quote 130.22.32.68

  4. #4
    Unregistered
    Guest
    Location
    , ,
    Member No: Unregistered's Avatar


    Yes | No

    transmission problem on 98 E46 323i bmw

    Quote Originally Posted by Unregistered View Post
    Hi,

    Did the on/off 6 times work for you? I have the same issue. My indie mechanic doesn't know what it is but he suspects something is causing an irregular voltage which trigers the warning light. Battery, alternator are all fine. No aftermarket other than angel eyes which I've had for 4 years and never had this issue before. Car does not go into limp mode amd gears shift fine but (!) indicator comes on and off. This started right before water pump died out but this was replaced and the indicator still comes on. Thanks!
    I have had the above problems too, and it's linked to the aircon . I was of the opinion that when the aircon compressor was activated ( and engine revs increase accordingly ) this may cause the transmission to think it's slipping, suffering voltage drop or a transmission ecu fault. Either way it's related to the engine revving by itself and the computer thinking it's faulty.
    I have tried very scenario on the auto trans ( sport mode, manual, park every gear) the only position it will not cause fault is when you stop at lights etc, put into neutral N. It does not go into fault mode,strange.
    I've tried my peake computer tester on car but no faults come up. I think you have to go to a mechanic to get tranny computer tested.

    I have had allot done to car just recently, i will list a few that other people said may have contributed to the problem.

    New engine computer
    Coils
    Leads
    Maf
    Aircon compressor
    Engine sensors ALL
    New tranny fluid ( REDLINE as recommended by Germany)
    Radiator and coolant at correct percentage

    This car is meticulously maintained, oil change every 5 to the 6000kms
    Just got re conditioned head, new vanos ( Dr Vanos )
    Damn cars like new

    I have turned my ignition on and off 6 times like mentioned, so will see if this works.

    If anyone finds out what the hell is going on, please keep us all up to date.

    Cheers and good luck
    Reply With Quote Reply With Quote 58.7.101.201

  5. #5
    Unregistered
    Guest
    Location
    , ,
    Member No: Unregistered's Avatar


    Yes | No
    Quote Originally Posted by Unregistered View Post
    I have had the above problems too, and it's linked to the aircon . I was of the opinion that when the aircon compressor was activated ( and engine revs increase accordingly ) this may cause the transmission to think it's slipping, suffering voltage drop or a transmission ecu fault. Either way it's related to the engine revving by itself and the computer thinking it's faulty.
    I have tried very scenario on the auto trans ( sport mode, manual, park every gear) the only position it will not cause fault is when you stop at lights etc, put into neutral N. It does not go into fault mode,strange.
    I've tried my peake computer tester on car but no faults come up. I think you have to go to a mechanic to get tranny computer tested.

    I have had allot done to car just recently, i will list a few that other people said may have contributed to the problem.

    New engine computer
    Coils
    Leads
    Maf
    Aircon compressor
    Engine sensors ALL
    New tranny fluid ( REDLINE as recommended by Germany)
    Radiator and coolant at correct percentage

    This car is meticulously maintained, oil change every 5 to the 6000kms
    Just got re conditioned head, new vanos ( Dr Vanos )
    Damn cars like new

    I have turned my ignition on and off 6 times like mentioned, so will see if this works.

    If anyone finds out what the hell is going on, please keep us all up to date.

    Cheers and good luck
    Hey guys,

    I've got an 03 316ti. I was suffering the same problems. I didn't have a chance to take it into a transmission shop. However, I knew my coils were nearing their use by date... I changed them, and viola, problem fixed... No idea why the coils would make my transmission shoddy...
    Reply With Quote Reply With Quote 122.108.170.178

  6. #6
    Jason Keown
    Guest
    Location
    , ,
    Member No: Jason Keown's Avatar


    Yes | No

    Mr

    Hi all same problem have all new coils but problem persists. Car also hesitates now and then when I pull off? Going mad as car kept in perfect condition hate having this problem have to keep turning air on off. Help!
    Reply With Quote Reply With Quote 197.229.109.86

  7. #7
    User Level 1
    Location
    , ,
    Member No: 200591 Jereld is an unknown quantity at this point Jereld's Avatar
    Join Date
    Mar 2014
    Posts
    1
    Rep Power
    0


    Yes | No
    I have a BMW 325I (2002) will driving the car started to lose momentum while foot on gas...as I came to a stop sign...and hit the gas the car barely drove forward...stopped at a service station..puddle underneath car...now car will not drive forward and backwards...(transmission)..is this simply a trans hose issue?
    Reply With Quote Reply With Quote 66.170.94.30

  8. #8
    Unregistered
    Guest
    Location
    , ,
    Member No: Unregistered's Avatar


    Yes | No

    2002 Bmw 325Ci Coupe

    I'm having the same problems withmy transmission and the lose of momentum while my foot is on the gas for the first time today I received a warning symbol the one that looks like a exclamation mark inside a gear it stayed on for about 20 minutes until I got to work an when I turned the car back on it was gone but I can feel the transmission when it shifts gears I just want to make sure it isn't the computer and is actually the transmission before I replace it. Can anyone help on how to diagnose what it actually is so I fix it before it gets worse??
    Reply With Quote Reply With Quote 108.162.212.34

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. 2000 BMW 323ci auto. - transmission warning light
    By Ann in forum BMW 3 Series Forum (E46)
    Replies: 5
    Last Post: 01-23-2017, 01:13 AM
  2. NE1 have transmission warning light? (m)
    By italia330i in forum BMW 3 Series Forum (E46)
    Replies: 3
    Last Post: 08-06-2014, 09:32 AM
  3. Transmission Warning Light on...323Ci
    By jolson in forum BMW 3 Series Forum (E46)
    Replies: 4
    Last Post: 01-14-2001, 05:45 AM
  4. Steptronic Transmission Warning Light Update
    By Eugene Oh in forum BMW 3 Series Forum (E46)
    Replies: 0
    Last Post: 07-15-1999, 12:28 AM
  5. Steptronic Transmission Warning Light
    By Eugene Oh in forum BMW 3 Series Forum (E46)
    Replies: 7
    Last Post: 07-13-1999, 07:27 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum