+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    User Level 1
    Location
    San Diego, CA,
    Member No: 193483 gio14 is an unknown quantity at this point gio14's Avatar
    Join Date
    Aug 2012
    Posts
    3
    Rep Power
    0


    Yes | No

    Z3 99 2.8 Coupe Automatic Transmission Slipping

    Hi All, I am have transmission problems on and off for the last 6 months. Automatic transmission z3 '99 2.8. Randomly the car seems to slip out of gear, i give gas it revs up high but barely moves, sometimes letting of the gas and giving it a second will usually pop it back into gear, this usually happens when slowing down to a stop and taking off again. I have had my service engine light on, ABS and traction light. But they sometimes all go off or just the service engine goes off. It has happen a handful of times but i noticed when im in a hurry and driving harder, stop n go it will usually pull a slip, so needless to say I've been driven like grandpa'.

    Went to my mechanic we put it on the scanner and the abs pump came up at fault and the torque converter. We decided to flash it, drove the car for 2 days no lights, then only the abs and traction light would come on, no code for transmission or torque converter. Service engine seems to come and go but abs and traction seem to be sticking. Went back to mechanic on 3rd day codes for torque converter and abs pump came up. Cleared them again and torque converter code was not showing up... Something is prompting he torque converter but it doesn't seem to appear consistently.

    At first my mechanic thought the ABS and traction could be causing the torque converter code and causing the transmission issues, but after further discussion with a mechanic from the BMW dealership seems new models could have that issue caused by ABS but not a 99.

    Can the gear head gurus please help shed light on the issue, the rest of my car is mint. I've kept everything tip top, but now with this transmission issue the car is not leaving me confident, last time it happened it took a while and i had to pull over keep it off for 15 min b4 i could get it going again. BTW the tranny fluid was changed to try to address this 4 months ago.
    Reply With Quote Reply With Quote 160.33.43.65


  2. #2
    Registered Member
    Location
    Rio Rancho, NM, United States
    Member No: 137549 Marty505 is on a distinguished road Marty505's Avatar
    Join Date
    Feb 2006
    Posts
    589
    Rep Power
    13


    Yes | No
    The most common cause of slippage is low fluid level. Since the transmission doesn't have a dipstick it's a slightly nasty job to check the level. The car has to be up to temperature and the fill plug has to be removed while the car is running and up in the air on a lift or jack stands. And the bottom of the transmission, the pan, has to be level. If it is full the fluid will be at or slightly above the bottom of the fill hole. If the plug is removed and nothing comes out it's low, add fluid until it does come out. A messy job made worse by working underneath a hot running car. If you try to fill it when it's not running the level will be too low. If that's not the problem your transmission probably needs a rebuild.
    Reply With Quote Reply With Quote 184.155.197.245

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. 2001 XK8 automatic transmission slipping
    By Ed in forum Jaguar X-Type Forum
    Replies: 1
    Last Post: 03-17-2006, 01:15 PM
  2. Automatic transmission slipping 2-3
    By haileyn in forum BMW 3 Series Forum (E36)
    Replies: 4
    Last Post: 03-08-2004, 12:44 PM
  3. automatic transmission whines on my 99 z3
    By george in forum BMW Z3 Roadster Forum & M Roadster Forum (E36, E37)
    Replies: 0
    Last Post: 03-10-2001, 02:04 AM
  4. automatic transmission slipping
    By Dave Lehmann in forum BMW 3 Series Forum (E36)
    Replies: 0
    Last Post: 11-20-1999, 08:40 PM
  5. Z3 Automatic Transmission?
    By Oliver in forum BMW Z3 Roadster Forum & M Roadster Forum (E36, E37)
    Replies: 7
    Last Post: 11-27-1998, 06:20 AM

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum