+ Reply to Thread
Results 1 to 11 of 11
  1. #1
    User Level 1
    Location
    , ,
    Member No: 193928 diva24x7 is an unknown quantity at this point diva24x7's Avatar
    Join Date
    Aug 2012
    Posts
    1
    Rep Power
    0


    Yes | No

    BMW X5 trans failsafe program problems

    Hello, I have a 2002 BMW X5 and for the pass 3 weeks it occassionally locks up in 3rd gear while I am driving. I then have to pull over and cut the car off and sometimes put in manual and then back to automatic for it to clear up. I took it to a BMW dealership and they could not produce any fault codes but told me to replace my transmission. Yesterday, the car started and while driving became sluggish and then trans. failsafe prog message appeared. I pulled over and cut the car off and then the car would not start. Now the BMW dealership is telling me that my alternator needs to be replaced. Has anyone experienced this or similiar before. Thanks.
    Reply With Quote Reply With Quote 214.4.253.121


  2. #2
    Registered Member
    Location
    , ,
    Member No: 147626 94583 is an unknown quantity at this point 94583's Avatar
    Join Date
    Dec 2006
    Posts
    52
    Rep Power
    0


    Yes | No
    Sounds like their diagnosis could be right on, assuming that there is power supply faults within the EGS. If the charging system is not operating properly the EGS may not operate properly. If you have gear monitoring faults and high mileage I would suspect possible internal transmission failure.
    Reply With Quote Reply With Quote 24.4.252.222

  3. #3
    Registered Member
    Location
    , ,
    Member No: 34281 bobthebuilder is an unknown quantity at this point bobthebuilder's Avatar
    Join Date
    Apr 2002
    Posts
    69
    Rep Power
    0


    Yes | No
    I had this same thing happen 3 times over 165,000 miles, first time at 50K. I was told to replace the trans, which I never did do, as it didn't make sense. I eventually learned offline from a mechanic that I was experiencing a voltage drop which causes the trans to go into fail safe mode. All three times, I had the lights, fogs, wipers, defrost/AC and radio going during heavy rain, which could cause a voltage drop. So I'd say the alternator diagnosis is right on.
    Reply With Quote Reply With Quote 65.5.226.82

  4. #4
    User Level 1
    Location
    Columbus, Ohio, USA
    Member No: 196079 Dmann2 is an unknown quantity at this point Dmann2's Avatar
    Join Date
    Nov 2012
    Posts
    1
    Rep Power
    0


    Yes | No
    2000 x5 driving last night , lights & fogs on, front & rear windshield wipers on, heat on, on the freeway and trans fail safe clicks on, will not come out of 3 rd gear, bobthebuilder said the alternator fixed his problem, so diva24x7 what was your outcome ? The sad thing is my 540i is doing the same thing!
    Reply With Quote Reply With Quote 76.209.75.67

  5. #5
    Registered Member
    Location
    , ,
    Member No: 34281 bobthebuilder is an unknown quantity at this point bobthebuilder's Avatar
    Join Date
    Apr 2002
    Posts
    69
    Rep Power
    0


    Yes | No
    Actually, I never replaced the alternator. I chalked it up to a big voltage draw and drove another 50K miles before it happened again. If the OP's alternator was diagnosed as faulty, it could well be the cause of his trans fail safe problem.
    Reply With Quote Reply With Quote 65.5.226.82

  6. #6
    Registered Member
    Location
    Spotsylvania, VA, United States
    Member No: 34568 JMD540IS is an unknown quantity at this point JMD540IS's Avatar
    Join Date
    Apr 2002
    Posts
    890
    Rep Power
    0


    Yes | No
    Registered Member Location Spotsylvania, VA, United StatesMember No: 34568
    --------------------------------------------------------------------------------
    Join Date: Apr 2002Posts: 886Rep Power:0
    I just made this post to "xalaskan" thread and I see that other here have somewhat replied similar to your post. GL!

    I would have the Tech check the Alternator (...more important, the Voltage Regulator). Case in point, I have an '05 4.8is and there was a time that the Voltage Regulator (VR) was causing crazy electrical havoc with my X5. First, the engine would randomly completely die at any given speed,...at any given time,...the ABS system would kick in,...rear tires only,...and the tranny would "Failsafe" to 3rd gear! Within 2 seconds of the onset of this issue, I could prevent the seriouse "Failsafe" clunk on the drivetrain by immediately shifting to "Neutral",...and killing the ignition and restarting the engine. Yes, I knew it was dangerous,...but at least I knew exactly the cause and affect. Anyway, the dealer told me with that it was my VR and the cost to repair was no estimate,...and he quoted a whopping $900+. I could not believe that any automobile between here (USA) and Egypt had an alternator that was priced at a whopping $900+. Hey,..but the X5 4.8is does. Anyway, I saved up a few $$$ to have the repair done and thus far,..knocking on an Oak Tree, things have been un eventful for the most part.
    Reply With Quote Reply With Quote 50.193.132.185

  7. #7
    Registered Member
    Location
    , ,
    Member No: 34281 bobthebuilder is an unknown quantity at this point bobthebuilder's Avatar
    Join Date
    Apr 2002
    Posts
    69
    Rep Power
    0


    Yes | No
    Just ticked over 171000 and the "battery" icon came on. Had a buddy with a repair shop check it out and and my alternator is toast. I can't complain - 11 yrs and 171K on the original alternator. I don't think the alternator was my problem with the trans safe since it has been years since it first started happening. My buddy quoted $790 for parts and labor. Very reasonable, given the rebuilt Bosch alternator alone is $500. I told him to replace the serpentine belt and if needed, pulleys and tensioner.
    Reply With Quote Reply With Quote 65.5.226.82

  8. #8
    Unregistered
    Guest
    Location
    , ,
    Member No: Unregistered's Avatar


    Yes | No

    2002 bww x5

    Wow, I wish I would have fond this thread before today.

    I never heard of the voltage drop causing the Trans fail safe to come on.

    I have had this happening everyday for the last 3 or 4 months. Everyone kept telling me to replace the transmission. With 170K miles that
    ain't happening. I'll drive it til it quits then leave it on the side of the road before I spend $6000.

    Anyway, today while I was sitting waiting for my son at the train station the battery went dead. I jumped it and took it to Pep Boys.
    The alternator is toast. $400 rebuilt installed.

    NO MORE TRANS FAIL SAFE MESSAGE. Glad I didn't replace the transmission.

    I figure the alternator has been going over the last 3 months and couldn't keep up with the voltage demand... ipso facto presto chango causing the TFS warning to come on. $400 is less than $6000... Why didn't no less than 4 different BMW techs suggest this? Because $400 is less than $6000......I suppose.
    Reply With Quote Reply With Quote 71.225.157.161

  9. #9
    HABURNETT
    Guest
    Location
    , ,
    Member No: HABURNETT's Avatar


    Yes | No

    Great Info

    This thread is great! Fail Safe Trans (FST) started flashing when my battery light and service engine light came on for my 2002 530i w/only 80,000 miles on it. The battery was 5 yrs old and my tech said the alternator definitely needed to be replaced along with a new thermostat. The FST light was my major concern because he we didn't have this info and I had no transmission problems. Great info from all of you!
    Reply With Quote Reply With Quote 173.66.127.49

  10. #10
    GR x5
    Guest
    Location
    , ,
    Member No: GR x5's Avatar


    Yes | No

    Transmission light

    I have had a 2005 and my current 2008 x5 with 105,000 miles. Transmission light would come on, usually when first starting car, car would run sluggish, like not have all cylinders firing, then eventually transmission light goes off, car runs fine. Never ever tranny issue. Dealership checked out and said and repaired voltage regulators and car did not need new tranny. After 2 months, tranny light coming back on again. What do you think before I head back to dealer?
    Reply With Quote Reply With Quote 98.178.148.124

  11. #11
    Unregistered
    Guest
    Location
    , ,
    Member No: Unregistered's Avatar


    Yes | No

    2002 BWM X5 - Trans. Failsafe Prog Issues

    I too am experiencing the same error code: Trans Failsafe Prog; my car is exhibiting the same issues you are experiencing; car goes into low gear, does not perform as an X5 does. I have to turn car off and then restart, goes a few miles before the error code appears again. Thank you all for commenting on your previous experience with this error code. I had a new transmission installed last April ($3500); glad to hear I may need an alternator fix.
    Reply With Quote Reply With Quote 15.211.201.81

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. HELP!! Had Trans.Failsafe Program appear on screen
    By WEGS540i in forum BMW 5 Series Forum (E39)
    Replies: 4
    Last Post: 01-23-2004, 11:31 AM
  2. Help please - trans. failsafe program
    By gandsleong in forum BMW 5 Series Forum (E39)
    Replies: 2
    Last Post: 01-03-2004, 10:56 PM
  3. Trans. failsafe program message.
    By andrew_thompsonuk in forum BMW 7 Series Forum (E38)
    Replies: 4
    Last Post: 01-03-2004, 04:26 PM
  4. Trans Failsafe program--help!!
    By paciullo in forum BMW 5 Series Forum (E39)
    Replies: 6
    Last Post: 03-16-2003, 05:50 PM
  5. AT warning light, trans. failsafe program (long)
    By Erik in forum BMW 3 Series Forum (E36)
    Replies: 1
    Last Post: 08-07-2000, 07:09 AM

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum